hdu 5890(01背包+ bitset 优化)

6 篇文章 0 订阅

Eighty seven

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 102400/102400 K (Java/Others)
Total Submission(s): 1605    Accepted Submission(s): 515


 

Problem Description

Mr. Fib is a mathematics teacher of a primary school. In the next lesson, he is planning to teach children how to add numbers up. Before the class, he will prepare Ncards with numbers. The number on the i-th card is ai. In class, each turn he will remove no more than 3 cards and let students choose any ten cards, the sum of the numbers on which is 87. After each turn the removed cards will be put back to their position. Now, he wants to know if there is at least one solution of each turn. Can you help him?

 

 

Input

The first line of input contains an integer t (t≤5), the number of test cases. t test cases follow.
For each test case, the first line consists an integer N(N≤50).
The second line contains N non-negative integers a1,a2,...,aN. The i-th number represents the number on the i-th card. The third line consists an integer Q(Q≤100000). Each line of the next Q lines contains three integers i,j,k, representing Mr.Fib will remove the i-th, j-th, and k-th cards in this turn. A question may degenerate while i=j, i=k or j=k.

 

 

Output

For each turn of each case, output 'Yes' if there exists at least one solution, otherwise output 'No'.

 

 

Sample Input

 

1 12 1 2 3 4 5 6 7 8 9 42 21 22 10 1 2 3 3 4 5 2 3 2 10 10 10 10 11 11 10 1 1 1 2 10 1 11 12 1 10 10 11 11 12

 

 

Sample Output

 

No No No Yes No Yes No No Yes Yes

 

 

Source

2016 ACM/ICPC Asia Regional Qingdao Online

 

 

Recommend

wange2014   |   We have carefully selected several similar problems for you:  6379 6378 6377 6376 6375 

 

题意: 现在给你n个数,每次查询问从点集中删去 x,y,z 三个数,你要从其他的剩下的数中能否找出10个数使得十个数相加为87?

思路: 背包来做,由于n 比较小,所以我可以预先处理出所有的情况,然后用bitset 搞一搞。

另附一句  bitset 真的强。 

推荐题集: 大神大神

代码:

#include<bits/stdc++.h>

using namespace std;
const int N =55;
int a[N];
int flag[N][N][N];
int n;
bitset<100>dp[12];

int jud(int aa,int b,int c)
{
    for(int i=1;i<=11;i++) dp[i].reset();
    dp[0][0]=1;
    for(int i=1;i<=n;i++){
        for(int j=9;j>=0;j--){
            if(i==aa) continue;
            if(i==b) continue;
            if(i==c) continue;
            dp[j+1]|=(dp[j]<<a[i]);
        }
    }
    if(dp[10][87]==1) return 1;
    return 0;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        memset(flag,0,sizeof(flag));
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
        }

        for(int i=1;i<=n;i++){
            for(int j=i;j<=n;j++){
                for(int k=j;k<=n;k++){
                    if(jud(i,j,k)){
                        //cout<<"i "<<i<<" j "<<j<<" k "<<k<<endl;
                        flag[i][j][k]=1; flag[i][k][j]=1;
                        flag[j][i][k]=1; flag[j][k][i]=1;
                        flag[k][i][j]=1; flag[k][j][i]=1;
                    }
                }
            }
        }
        int m;
        scanf("%d",&m);
        while(m--)
        {
            int aa,b,c;
            scanf("%d %d %d",&aa,&b,&c);
            if(flag[aa][b][c]) printf("Yes\n");
            else printf("No\n");
        }

    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值