POJ:2060-Taxi Cab Scheme(最小路径覆盖)

传送门:http://poj.org/problem?id=2060

Taxi Cab Scheme

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 7260 Accepted: 2972

Description

Running a taxi station is not all that simple. Apart from the obvious demand for a centralised coordination of the cabs in order to pick up the customers calling to get a cab as soon as possible,there is also a need to schedule all the taxi rides which have been booked in advance.Given a list of all booked taxi rides for the next day, you want to minimise the number of cabs needed to carry out all of the rides.
For the sake of simplicity, we model a city as a rectangular grid. An address in the city is denoted by two integers: the street and avenue number. The time needed to get from the address a, b to c, d by taxi is |a - c| + |b - d| minutes. A cab may carry out a booked ride if it is its first ride of the day, or if it can get to the source address of the new ride from its latest,at least one minute before the new ride’s scheduled departure. Note that some rides may end after midnight.

Input

On the first line of the input is a single positive integer N, telling the number of test scenarios to follow. Each scenario begins with a line containing an integer M, 0 < M < 500, being the number of booked taxi rides. The following M lines contain the rides. Each ride is described by a departure time on the format hh:mm (ranging from 00:00 to 23:59), two integers a b that are the coordinates of the source address and two integers c d that are the coordinates of the destination address. All coordinates are at least 0 and strictly smaller than 200. The booked rides in each scenario are sorted in order of increasing departure time.

Output

For each scenario, output one line containing the minimum number of cabs required to carry out all the booked taxi rides.

Sample Input

2
2
08:00 10 11 9 16
08:07 9 16 10 11
2
08:00 10 11 9 16
08:06 9 16 10 11

Sample Output

1
2


解题心得:

  1. 题意就是每个乘客有一个时间点要从一个地点去另一个地点,的士司机花费的时间就是起点到目的地的曼哈顿距离(|x1-x2| + |y1-y2|),问要满足所有的乘客最少需要多少个的士。
  2. 这个题建图真的是很精彩,把每一个订单处理成一个点,这个点有开始时间和花费的时间的信息。然后如果一个司机能够在送完这个乘客,然后赶到另一个乘客的起点,时间还在另一个乘客需要乘车之前那么就可以把这两个订单联系起来,最后求一个最小路径覆盖。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 510;
struct Node
{
    int st,va,x1,x2,y1,y2;
}node[maxn];
bool maps[maxn][maxn],vis[maxn];
int n,match[maxn];

void init()
{
    memset(match,-1,sizeof(match));
    memset(maps,0,sizeof(maps));
    for(int i=1;i<=n;i++)
    {
        int h,m;
        char s[10];
        int x1,x2,y1,y2,st,en;
        scanf("%d:%d%d%d%d%d",&h,&m,&x1,&y1,&x2,&y2);
        st = h*60+m;//为了方便将时间全部处理成分钟
        en = abs(x1-x2) + abs(y1-y2);
        //一个订单开始时间,结束时间,起点,终点
        node[i].st = st;
        node[i].va = en;
        node[i].x1 = x1;
        node[i].y1 = y1;
        node[i].x2 = x2;
        node[i].y2 = y2;
    }
    for(int i=1;i<=n;i++)
        for(int j=i+1;j<=n;j++)
        {
            int x1 = node[i].x1;
            int y1 = node[i].y1;
            int x2 = node[i].x2;
            int y2 = node[i].y2;
            int sp_time = node[i].va + abs(x2-node[j].x1) + abs(y2 - node[j].y1);//计算如果这个司机完成了i订单要去接j订单是否来得及
            if(node[j].st - node[i].st > sp_time)
                maps[i][j] = true;
        }
}

bool dfs(int x)
{
    for(int i=1;i<=n;i++)
    {
        if(!vis[i] && maps[x][i])
        {
            vis[i] = true;
            if(match[i] == -1 || dfs(match[i]))
            {
                match[i] = x;
                return true;
            }
        }
    }
    return false;
}

int solve()
{
    int ans = 0;
    for(int i=1;i<=n;i++)
    {
        memset(vis,0,sizeof(vis));
        if(dfs(i))
            ans++;
    }
    return ans;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        init();
        int ans = solve();
        printf("%d\n",n-ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值