poj 1505 dp/二分+贪心 序列划分模型

题意:n本书分给m个人,要求 负责页数最多的人 所负责页数的最小值  ,输出分法
解法:二分/dp +贪心输出。
贪心输出:从后往前,每次都使得最后面的人作尽量大的工作

Copying Books
Time Limit: 3000MS Memory Limit: 10000K
Total Submissions: 7812 Accepted: 2477

Description

Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so called scribers. The scriber had been given a book and after several months he finished its copy. One of the most famous scribers lived in the 15th century and his name was Xaverius Endricus Remius Ontius Xendrianus (Xerox). Anyway, the work was very annoying and boring. And the only way to speed it up was to hire more scribers. 

Once upon a time, there was a theater ensemble that wanted to play famous Antique Tragedies. The scripts of these plays were divided into many books and actors needed more copies of them, of course. So they hired many scribers to make copies of these books. Imagine you have m books (numbered 1, 2 ... m) that may have different number of pages (p1, p2 ... pm) and you want to make one copy of each of them. Your task is to divide these books among k scribes, k <= m. Each book can be assigned to a single scriber only, and every scriber must get a continuous sequence of books. That means, there exists an increasing succession of numbers 0 = b0 < b1 < b2, ... < b k-1 <= bk = m such that i-th scriber gets a sequence of books with numbers between bi-1+1 and bi. The time needed to make a copy of all the books is determined by the scriber who was assigned the most work. Therefore, our goal is to minimize the maximum number of pages assigned to a single scriber. Your task is to find the optimal assignment. 

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly two lines. At the first line, there are two integers m and k, 1 <= k <= m <= 500. At the second line, there are integers p1, p2, ... pm separated by spaces. All these values are positive and less than 10000000.

Output

For each case, print exactly one line. The line must contain the input succession p1, p2, ... pm divided into exactly k parts such that the maximum sum of a single part should be as small as possible. Use the slash character ('/') to separate the parts. There must be exactly one space character between any two successive numbers and between the number and the slash. 

If there is more than one solution, print the one that minimizes the work assigned to the first scriber, then to the second scriber etc. But each scriber must be assigned at least one book.

Sample Input

2
9 3
100 200 300 400 500 600 700 800 900
5 4
100 100 100 100 100

Sample Output

100 200 300 400 500 / 600 700 / 800 900
100 / 100 / 100 / 100 100

Source


#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<vector>
#include<iomanip>
using namespace std;

#define all(x) (x).begin(), (x).end()
#define for0(a, n) for (int (a) = 0; (a) < (n); (a)++)
#define for1(a, n) for (int (a) = 1; (a) <= (n); (a)++)
typedef long long ll;
typedef pair<int, int> pii;
const int INF =0x3f3f3f3f;
const ll inf=1e15;
const int maxn= 500   ;
int n,m;
ll a[maxn+10];
ll dp[maxn+10][maxn+10];
ll sum[maxn+10];
ll ans;
int best[maxn+10];
int cnt=0;

void print(ll x)
{
    if(cnt++) putchar(' ');
    printf("%lld",x);
}
void print(char x)
{
    if(cnt++) putchar(' ');
    printf("%c",x);
}
void work()//求解负责页数最多的人 所负责页数的最小值
{
    sum[0]=0;
    for1(i,n)
    {
       sum[i]=sum[i-1]+a[i];
    }
    for0(i,n+1)
    {
        dp[1][i]=sum[i]-sum[0];
    }

    for(int i=2;i<=m;i++)
    {
        for(int now=i;now<=n-(m-i);now++)
        {
            dp[i][now]=inf;
//            printf("cal i=%d  ,now=%d\n",i,now);
            for(int p=i-1;p<now;p++)
            {
                ll ret=max(dp[i-1][p],sum[now]-sum[p]);
//                printf("use  i-1=%d  ,p=%d ,dp=%lld\n",i-1,p,dp[i-1][p]);
                dp[i][now]=min(dp[i][now],ret);
            }
//            printf("i=%d  ,now=%d ,dp=%lld\n",i,now,dp[i][now]);
        }
    }
//    printf("%lld\n",dp[m][n]);

     ans=dp[m][n];
}
void find(int pos,int ind)//做标记,存放每一组画杠的位置
{
    if(ind==1)
    {
        return;
    }
    ll sum=a[pos];
    int p=pos;
    while(sum+a[p-1]<=ans&& p-2>=ind-1)
    {
        p--;
        sum+=a[p];
    }
    best[ind-1]=p-1;
//    printf("best[%d] is  %d\n",ind-1,p-1);
    find(p-1,ind-1);



}

void out()//输出答案
{
    cnt=0;
    int now=1;
    for(int i=1;i<m;i++)
    {
        int p=best[i];
        while(now<=p) print(a[now++]);

        print('/');

    }
    while(now<=n)
    {
        print(a[now++]);
    }

    putchar('\n');
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for1(i,n)
        {
            scanf("%lld",&a[i]);
        }
        work();
        find(n,m);
        out();
    }

   return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值