414 - Machined Surfaces

An imaging device furnishes digital images of two machined surfaces thateventually will be assembled in contact with each other. The roughness of thisfinal contact is to be estimated.

A digital image is composed of the two characters, "X" and" " (space). There are always 25 columns to an image, but the numberof rows, N, is variable. Column one (1) will always have an"X" in it and will be part of the left surface. The left surface canextend to the right from column one (1) as contiguous X's.

Similarly, column 25 will always have an "X" in it and will bepart of the right surface. The right surface can extend to the left from column25 as contiguous X's.

Digital-Image View of Surfaces

 

                Left                                            Right

 

 

 

                XXXX                                             XXXXX    

 

                XXX                                            XXXXXXX

 

                XXXXX                                             XXXX

 

                XX                                              XXXXXX

 

                .                                                    .

 

                .                                                    .

 

                .                                                    .

 

                XXXX                                              XXXX

 

                XXX                                             XXXXXX      

 

                                                                 

 

                1                                               25

 

In each row of the image, there can be zero or more space charactersseparating the left surface from the right surface. There will never be morethan a single blank region in any row.

For each image given, you are to determine the total ``void" thatwill exist after the left surface has been brought into contact with the rightsurface. The ``void" is the total count of the spaces that remains betweenthe left and right surfaces after theyhave been brought into contact.

The two surfaces are brought into contact by displacing them strictlyhorizontally towards each other until a rightmost "X" of the leftsurface of some row is immediately to the left of the leftmost "X" ofthe right surface of that row. There is no rotation or twisting of these twosurfaces as they are brought into contact; they remain rigid, and only movehorizontally.

Note: The original image may show thetwo surfaces already in contact, in which case no displacement enters into thecontact roughness estimation.

Input

The input consists of a series of digital images. Each image data set hasthe following format:

First line -

A single unsignedinteger, N, with value greater than zero (0) and less than 13. The firstdigit of N will be the first character on a line.

Next N lines -

Each line hasexactly 25 characters; one or more X's, then zero or more spaces, then one ormore X's.

The end of data is signaled by a null data set having a zero on the firstline of an image data set and no further data.

Output

For each image you receive as a data set, you are to reply with the totalvoid (count of spaces remaining after the surfaces are brought into contact).Use the default output for a single integer on a line.

SampleInput (character "B" for ease ofreading. The actual input file will use the ASCII-space character, not"B").

4

XXXXBBBBBBBBBBBBBBBBXXXXX

XXXBBBBBBBBBBBBBBBXXXXXXX

XXXXXBBBBBBBBBBBBBBBBXXXX

XXBBBBBBBBBBBBBBBBBXXXXXX

2

XXXXXXXXXXXXXXXXXXXXXXXXX

XXXXXXXXXXXXXXXXXXXXXXXXX

1

XXXXXXXXXBBBBBBBBBBBBBBXX

0

SampleOutput

4

0

0

 

#include <stdio.h>
#include <string.h>

int main(void)
{
	int i,j,k,n,a=-1;
	int sum,line_blank,min,left[100];
	char str[1000];

	while(scanf("%d",&n) != EOF)
	{
		getchar();
		if(n == 0)
			break;
		a++;
		min=1000;
		sum=0;
		for(i=0;i<n;i++)
		{
			memset(str,0,strlen(str));
			gets(str);
			k = strlen(str);
			line_blank=0;
			for(j=0;j<k;j++)
			{
				if(str[j] == ' ')
					line_blank++;
			}
			if(min > line_blank) min=line_blank;
			sum += line_blank;
		}
		left[a]=sum-n*min;
	}
	for(i=0;i<=a;i++)
		printf("%d\n",left[i]);
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值