zcmu-1182(大数相减)

1182: a-b

Time Limit: 10 Sec   Memory Limit: 128 MB
Submit: 419   Solved: 165
[ Submit][ Status][ Web Board]

Description

求a-b的值

Input

第一行一个整数T,表示接下来有T行
每行两个整数是a,b,(0<=a,b<=10^10000)

Output

输出值

Sample Input

2100 98100000000000000000000 1

Sample Output

299999999999999999999

HINT

Source


代码;

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

char a[10005],b[10005];
void sub(char a[], int n, char b[], int m)
{
    int z=0;
    for( ; n>=0; n--, m--)
    {
        if(m>=0)
            a[n] = a[n] - b[m] + '0';
        else
            a[n] =  a[n];
        if(a[n] < '0')
        {
            a[n] = a[n] +10;
            a[n-1]--;
        }
    }
    while(a[z] == '0')
            z++;
        a = a+z;
        printf("%s\n",a);
}
void change(char a[], int n, char b[], int m)
{
    if(n>m)
    {
        sub(a, n, b, m);
        return ;
    }
    if(n<m)
    {
        printf("-");
        sub(b, m, a, n);
        return ;
    }
    if(n==m)
    {
        if(strcmp(a, b) > 0)
        {
            sub(a, n, b, m);
            return ;
        }
        else if(strcmp(a, b) <0)
        {
            printf("-");
            sub(b, m, a, n);
            return ;
        }
        else
            printf("0\n");
            return ;
    }
}
int main()
{
    int t,n,m;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s %s",a,b);
        n=strlen(a)-1;
        m=strlen(b)-1;
        change(a,n,b,m);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值