POJ 题目2182 Lost Cows(树状数组+二分)

Lost Cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9347 Accepted: 6020

Description

N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands. 

Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow. 

Given this data, tell FJ the exact ordering of the cows. 

Input

* Line 1: A single integer, N 

* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on. 

Output

* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0

Sample Output

2
4
5
3
1

Source

 比如这道题意思就是有n头牛,编号1~n,知道每头牛后边比它编号小的牛数目,让输出这n头牛的编号~
ac代码
#include<stdio.h>
#include<string.h>
int a[10000],n,t[10000],ans[10000];
int low(int x)
{
	return x&(-x);
}
void add(int p,int q)
{
	while(p<=n)
	{
		a[p]+=q;
		p+=low(p);
	}
}
int sum(int p)
{
	int ans=0;
	while(p>0)
	{
		ans+=a[p];
		p-=low(p);
	}
	return ans;
}
int seach(int x)
{
	int l=1,r=n;
	int mid,temp;
	while(l<=r)
	{
		mid=(l+r)>>1;
		temp=sum(mid);
		if(temp>=x)//大于等于
			r=mid-1;
		else
			l=mid+1;
	}
	return l;
}
int main()
{
	//int n;
	while(scanf("%d",&n)!=EOF)
	{
		int i;
		memset(a,0,sizeof(a));
		for(i=1;i<=n;i++)
		{
			add(i,1);
		}
		for(i=2;i<=n;i++)
		{
			scanf("%d",&t[i]);
		}
		for(i=n;i>=1;i--)
		{
			ans[i]=seach(t[i]+1);
			add(ans[i],-1);
		}
		for(i=1;i<=n;i++)
			printf("%d\n",ans[i]);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值