Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 5707 | Accepted: 2259 |
Description
For their physical fitness program, N (2 ≤ N ≤ 1,000,000) cows have decided to run a relay race using the T (2 ≤ T ≤ 100) cow trails throughout the pasture.
Each trail connects two different intersections (1 ≤ I1i ≤ 1,000; 1 ≤ I2i ≤ 1,000), each of which is the termination for at least two trails. The cows know the lengthi of each trail (1 ≤ lengthi ≤ 1,000), the two intersections the trail connects, and they know that no two intersections are directly connected by two different trails. The trails form a structure known mathematically as a graph.
To run the relay, the N cows position themselves at various intersections (some intersections might have more than one cow). They must position themselves properly so that they can hand off the baton cow-by-cow and end up at the proper finishing place.
Write a program to help position the cows. Find the shortest path that connects the starting intersection (S) and the ending intersection (E) and traverses exactly N cow trails.
Input
* Line 1: Four space-separated integers: N, T, S, and E
* Lines 2..T+1: Line i+1 describes trail i with three space-separated integers: lengthi , I1i , and I2i
Output
* Line 1: A single integer that is the shortest distance from intersection S to intersection E that traverses exactly N cow trails.
Sample Input
2 6 6 4 11 4 6 4 4 8 8 4 9 6 6 8 2 6 9 3 8 9
Sample Output
10
Source
ac代码
本题的大意就是问从S 到 T 经过边得个数恰为k的最短路是多少。
ac代码
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <queue>
#define MAXN 1005
#define MAXM 500005
#define INF 1000000000
using namespace std;
int k, m, s, t;
int ans[MAXN][MAXN], mp[MAXN][MAXN], tmp[MAXN][MAXN], dis[MAXN][MAXN];
int used[MAXN], v[MAXN], num;
void floyd(int c[][MAXN], int a[][MAXN], int b[][MAXN])
{
for(int k = 0; k < num; k++)
for(int i = 0; i < num; i++)
for(int j = 0; j < num; j++)
if(c[v[i]][v[j]] > a[v[i]][v[k]] + b[v[k]][v[j]])
c[v[i]][v[j]] = a[v[i]][v[k]] + b[v[k]][v[j]];
}
void copy(int a[][MAXN], int b[][MAXN])
{
for(int i = 0; i < num; i++)
for(int j = 0; j < num; j++)
{
a[v[i]][v[j]] = b[v[i]][v[j]];
b[v[i]][v[j]] = INF;
}
}
void slove(int k)
{
while(k)
{
if(k & 1)
{
floyd(dis, ans, mp);
copy(ans, dis);
}
floyd(tmp, mp, mp);
copy(mp, tmp);
k >>= 1;
}
}
int main()
{
int x, y, w;
scanf("%d%d%d%d", &k, &m, &s, &t);
for(int i = 0; i <= 1000; i++)
{
for(int j = 0; j <= 1000; j++)
{
mp[i][j] = INF;
tmp[i][j] = INF;
dis[i][j] = INF;
ans[i][j] = INF;
}
ans[i][i] = 0;
}
num = 0;
for(int i = 0; i < m; i++)
{
scanf("%d%d%d", &w, &x, &y);
if(!used[x])
{
used[x] = 1;
v[num++] = x;
}
if(!used[y])
{
used[y] = 1;
v[num++] = y;
}
if(mp[x][y] > w)
mp[x][y] = mp[y][x] = w;
}
slove(k);
printf("%d\n", ans[s][t]);
return 0;
}