java某年某月的天数

Problem Description
输入年和月,判断该月有几天?
Input
输入年和月,格式为年\月。
Output
输出该月的天数。
Example Input
2009\1
Example Output
31
import java.util.Scanner;
public class Main 
{
 public static void main(String[] args) 
 {
  Scanner in=new Scanner(System.in);
     String s=in.nextLine();
     String a[]=s.split("\\\\");
     int year=Integer.parseInt(a[0]);
     int month=Integer.parseInt(a[1]);
     int flag=1;
     if(year%4==0&&year%100!=0||year%400==0)
  {flag=0;}
     if(month==1||month==3||month==5||month==7||month==8||month==10||month==12)
  {System.out.println("31");}
     else if(month==4||month==6||month==9||month==11)
  {System.out.println("30");}
     else if(month==2)
     {
      if(flag==1)
   {System.out.println("28");}
      else
   {System.out.println("29");}
     }
 }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值