poj 1753 (二进制枚举+模拟)

题目:

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
  1. Choose any one of the 16 pieces.
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example:

bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.
Input
The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.
Output
Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).
Sample Input
bwwb
bbwb
bwwb
bwww
Sample Output
4

题意:给你一个4*4的棋盘,'w'表示白子,'b'表示黑子。每次可以将一颗棋子及他的上下左右变为相反的颜色,通过这种操作,我们要把所有的子全变成一个颜色,问最小步数。如果不能将所有的子变成一个颜色输出"Impossible"。


思路:
因为是4*4只有16个棋子,所以我们可以用二进制状态压缩,用^=进行翻棋子的操作,当然我们要判断一下在不在棋盘内,接着就是枚举每个状态16个棋子翻的状态,进行判断,如果超过了16步就是不可能了,因为相当于一个棋子翻过去又翻回来,这样就没有意义。

代码如下:

#include<iostream>  
#include<cstdio>  
#include<cstring>  
#include<string>  
using namespace std;  
const int MAXN = 10;  
const int INF = 999999999;  
int n;  
int MAP[MAXN][MAXN], a[MAXN][MAXN];  
void Flip(int x, int y)//翻转操作  
{  
    a[x][y] = !a[x][y];    //本身进行翻转 
    a[x-1][y] = !a[x-1][y];  // 左边的进行翻转 
    a[x+1][y] = !a[x+1][y];  //右边的进行翻转 
    a[x][y-1] = !a[x][y-1];  //下边的那个翻转 
    a[x][y+1] = !a[x][y+1];  //上边的那个翻转 
}  
bool judge(int op)//最后一行是否全为op  
{  
    for (int j = 1; j <= n; j++)  
    {  
        if (a[n][j] != op) 
  return false;  
    }  
    return true;  
}  
int work(int op)//全变为op  
{  
    int cnt = 0, ans = INF;  
    for (int state = 0 ; state < (1<<n); state++) 
 //比如 1<<4  1的二进制为 0001 0000 左移4位 0001 0000. 如果再转成10进制就是16,左移n为也就是乘以2的n次方  
    {  
        cnt = 0;  
        memcpy(a, MAP, sizeof(MAP));  
        for (int j = 0; j < n; j++)  
        {  
            if (state&(1<<j)) 
   cnt++, Flip(1, j + 1);  
        }  
        for (int i = 2; i <= n; i++)  
        {  
            for (int j = 1; j <= n; j++)  
            {  
                if (a[i-1][j] != op) 
    cnt++, Flip(i, j);  
            }  
        }  
        if (judge(op)) 
  ans = min(ans, cnt);  
    }  
    return ans;  
}  
int main()  
{  
    n = 4;  
    for (int i = 1; i <= n; i++)  
    {  
        for (int j = 1; j <= n; j++)  
        {  
            char c; 
   cin >> c;  
            if (c == 'w') 
   MAP[i][j] = 0;  
            if (c == 'b') 
   MAP[i][j] = 1;  
        }  
    }  
    int ans = min(work(0), work(1));  
    if (ans != INF) 
 cout << ans << endl;  
    else 
 cout << "Impossible" << endl;  
    return 0;  
}  
/* 
bwwb 
bbwb 
bwwb 
bwww 
*/

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值