(PAT甲级)1051. Pop Sequence (25)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO
#include <iostream>
#include <stack>
using namespace std;

int main()
{
	int M, N, K;
	cin >> M >> N >> K;
	int *Arr = new int[N+1];        //存放待判断序列
	for (int i = 0; i < K; i++)     //要判断序列个数
	{
		stack<int> s;               //堆栈s
		int count = 0;              //用于判断序列中的每一个数是否都能从堆栈中pop出来
		for (int j = 1; j <= N; j++)//输入一个判断序列中的数
			cin >> Arr[j];
		for (int j = 1; j <= N; j++)//将123456按顺序push到堆栈中
		{
			s.push(j);
			if (s.size()> M) break;//堆栈存不下了,说明判断数列中的数和堆栈栈顶都不相等,那么这个数列肯定不存在
			while (!s.empty()&&(s.top() == Arr[count + 1]))//当堆栈不为空而且数列的元素和栈顶元素一样的时候,就要继续往下判断了
			{
				s.pop();
				count++;
			}
		}

		if (count == N) cout << "YES"<<endl;//当所有的数都pop出来的时候,count的数目应该和数列中的数一致
		else cout << "NO" << endl;
	}
	delete[]Arr;
	return 0;
}


`sltest.testsequence.addStepBefore` 函数的用法如下: ```matlab sltest.testsequence.addStepBefore(blockPath, newStep, stepPath) ``` 其中,`blockPath` 是要添加测试步骤的 Simulink 模块路径,`newStep` 是要添加的测试步骤,`stepPath` 是要添加新步骤的位置。这个函数将在 `stepPath` 指定的位置之前添加新步骤。 例如,我们可以使用以下代码在 Simulink Test Sequence 中添加一个测试步骤: ```matlab % 打开 Simulink Test Sequence testSeq = sltest.testmanager.getTestSuites('Test Sequence'); open(testSeq); % 获取 Test Sequence 中的第一个测试用例 testCase = getTestCases(testSeq); testCase = testCase{1}; % 获取测试用例中的第一个测试序列 testSeqObj = getTestSequences(testCase); testSeqObj = testSeqObj{1}; % 获取测试序列中第一个测试步骤的路径 stepPath = getTestSteps(testSeqObj); stepPath = stepPath{1}; % 在第一个测试步骤之前添加一个新的测试步骤 newStep = sltest.testsequence.TestStep('Description', '测试步骤描述'); blockPath = '模块名称/子系统名称'; sltest.testsequence.addStepBefore(blockPath, newStep, stepPath); ``` 在这个例子中,我们首先打开 Simulink Test Sequence,并获取第一个测试用例和第一个测试序列。然后,我们获取第一个测试步骤的路径,并使用 `sltest.testsequence.TestStep` 创建一个新的测试步骤。最后,我们使用 `sltest.testsequence.addStepBefore` 将新步骤添加到第一个测试步骤之前。
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值