nvm、nodejs、npm...安装与配置

环境变量:

CNPM_PATH D:\nodejs\node_global\node_modules\cnpm\bin

NODE_HOME D:\nodejs

NODE_PATH D:\nodejs\node_global\node_modules

PATH:

D:\nodejs\

%NODE_PATH%

%CNPM_PATH%

%NODE_HOME%\node_global

%NODE_HOME%

npm config set prefix "D:\nodejs\node_global"

npm config set cache "D:\nodejs\node_cache"

Releases · coreybutler/nvm-windows · GitHub

下载 nvm-setup.zip 解压 nvm-setup.exe → 安装

$ nvm -v

输入命令行nvm ls available查看可用的node.js版本号

$ nvm ls available

输入命令行nvm install node版本号

$ nvm install 17.7.2

安装成功后,记得先输入命令行nvm use node版本号

$ nvm use 17.7.2
$ node -v
$ npm -v

输入命令行nvm ls查看你安装的所有node.js版本号

$ nvm ls

如果想删除某node.js版本的话,输入命令行nvm uninstall node版本号(例如:nvm uninstall 12.17.0)即可删除对应版本

总结:使用nvm来管理node.js的版本真的很方便,这样就可以根据自己的需要来回切换node.js版本!

$ npm config set prefix "D:\nodejs\node_global"
$ npm config set cache "D:\nodejs\node_cache"
  $ npm install -g cnpm --registry=https://registry.npm.taobao.org

npm WARN deprecated har-validator@5.1.5: this library is no longer supported

npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142

npm WARN deprecated uuid@3.4.0: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details.

$ cnpm -v
cnpm@7.1.1 (d:\nvm\v17.7.2\node_global\node_modules\cnpm\lib\parse_argv.js)
npm@6.14.16 (d:\nvm\v17.7.2\node_global\node_modules\cnpm\node_modules\npm\lib\npm.js)
node@17.7.2 (D:\nodejs\node.exe)
npminstall@5.5.0 (d:\nvm\v17.7.2\node_global\node_modules\cnpm\node_modules\npminstall\lib\index.js)
prefix=D:\nodejs\node_global
win32 x64 10.0.19044
registry=https://registry.npmmirror.com

cnpm@7.1.1难道只适合npm@6.14.16?

官网:https://www.npmjs.com/ 因为node中自带npm,所以我们直接下载安装nodejs即可,也可以

升级npm

$ npm install -g npm

升级cnpm

$ npm -g i cnpm

执行“npm install @vue/cli -g”命令进行安装。“npm install @vue/cli -g” 命令是脚手架3的,“npm install vue-cli -g”命令才是脚手架2的,脚手架2和脚手架3是不相同的,如果现在使用 “npm install vue-cli -g”命令进行安装的话,下次使用脚手架3的时候就得卸载脚手架2,安装脚手架3,为了减少不必要的操作我们执行 “npm install  @vue/cli  -g ” 命令进行安装,然后再执行 “npm install @vue-cli-init -g ” 将脚手架2下载下来,在此环境下既可以安装脚手架2的模板,有可以安装脚手架3的模板。  检查是否安装成功终端执行“vue -V”或者"vue --version",如果显示具体的版本号则表示安装成功。具体安装方式查看官网(Vue CLI)。

$ npm install -g @vue/cli
# OR
$ yarn global add @vue/cli
  • 0
    点赞
  • 1
    收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
©️2022 CSDN 皮肤主题:大白 设计师:CSDN官方博客 返回首页
评论

打赏作者

乡村

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值