poj3974 Palindrome (最长回文子串)

Palindrome
Time Limit: 15000MS Memory Limit: 65536K
Total Submissions: 5686 Accepted: 2054

Description

Andy the smart computer science student was attending an algorithms class when the professor asked the students a simple question, "Can you propose an efficient algorithm to find the length of the largest palindrome in a string?" 

A string is said to be a palindrome if it reads the same both forwards and backwards, for example "madam" is a palindrome while "acm" is not. 

The students recognized that this is a classical problem but couldn't come up with a solution better than iterating over all substrings and checking whether they are palindrome or not, obviously this algorithm is not efficient at all, after a while Andy raised his hand and said "Okay, I've a better algorithm" and before he starts to explain his idea he stopped for a moment and then said "Well, I've an even better algorithm!". 

If you think you know Andy's final solution then prove it! Given a string of at most 1000000 characters find and print the length of the largest palindrome inside this string.

Input

Your program will be tested on at most 30 test cases, each test case is given as a string of at most 1000000 lowercase characters on a line by itself. The input is terminated by a line that starts with the string "END" (quotes for clarity). 

Output

For each test case in the input print the test case number and the length of the largest palindrome. 

Sample Input

abcbabcbabcba
abacacbaaaab
END

Sample Output

Case 1: 13
Case 2: 6

Source


解析:manacher算法。
代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 1000000
using namespace std;

int ans,id,mx,p[maxn*2+20];
char ss[maxn+20],s[maxn*2+20];

int main()
{
  int i,j,k=0,len;
  while(scanf("%s",ss),ss[0]!='E')
    {
      len=strlen(ss);
      s[0]='*',s[1]='#';
      for(i=0;i<len;i++)
        s[2*i+2]=ss[i],s[2*i+3]='#';
      len=2*len+1,ans=1,mx=0;
      for(i=1;i<len;i++)
        {
          if(mx>i)p[i]=min(p[2*id-i],mx-i);
          else p[i]=1;
          while(s[i+p[i]]==s[i-p[i]])p[i]++;
          if(i+p[i]>mx)mx=i+p[i],id=i;
          ans=max(ans,p[i]-1);
		}
	  printf("Case %d: %d\n",++k,ans);
	}
  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值