Dragon Balls HDU杭电3635 【并查集,递归的方法找根节点】

10 篇文章 0 订阅

Problem Description
Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together.

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.

Input
The first line of the input is a single positive integer T(0 < T <= 100).
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)

Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.

Sample Input
  
  
2 3 3 T 1 2 T 3 2 Q 2 3 4 T 1 2 Q 1 T 1 3 Q 1

Sample Output
  
  
Case 1: 2 3 0 Case 2: 2 2 1 3 3 2



#include<stdio.h>
int parent[101010];
int num[101001];//表示移动次数 
int rank[100010];//表示该地有多少颗龙珠 
int find(int x)
{
	if(x==parent[x]) return x;
	
    int t=parent[x];
    parent[x]=find(parent[x]);//压缩路径 ,都指向根节点 
    num[x]+=num[t];//每个球移动的次数等于本身移动的个数加上父节点移动的次数
    return parent[x];	 

//	int r=x;
//	while(r!=parent[r])
//	{
//		num[r]+=num[parent[r]]; //num需要通过加上父节点来更新 
//		r=parent[r];						
//	}		
//	int i=x,j;//路径压缩 
//	while(i!=r)
//	{		
//		j=parent[i];
//		parent[i]=r;
//		i=j;
//	}
//	return r;
}

void join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{
		parent[fx]=fy;//把fx的根节点赋予fy,即把城市fx的龙珠给城市移到fy 
		num[fx]=1;//头结点移动一次 
		rank[fy]+=rank[fx];//根节点代表城市 
	}
}

int main()
{
	int t;
	int n,m,a,b;
	int i;
	char ch;
	int cnt=0;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		getchar();
		for(i=1;i<=n;++i)
		{
			parent[i]=i;
			num[i]=0;
			rank[i]=1; 
		}
//		int flag=1;
		printf("Case %d:\n",++cnt);
		while(m--)
		{
			scanf("%c",&ch);
			if(ch=='T')
			{
				scanf("%d%d",&a,&b);
				getchar();
				join(a,b);//把a所在的城市的龙珠调到城市b 
			}
			else if(ch=='Q')
			{
				scanf("%d",&a);
				getchar();
				int temp=find(a); //找龙珠a在哪个城市,在找的时候不停的会加上它的父节点 
//				if(flag) {
//					printf("Case %d:",++cnt);
//					flag=0;
//				}
				printf("%d %d %d\n",temp,rank[temp],num[a]); 
			} 
		}
	}
	return 0;
}



#include<stdio.h>
int parent[101010];
int num[101001];//表示移动次数 
int rank[100010];//表示该地有多少颗龙珠 
int find(int x)
{
	if(x==parent[x]) return x;
	
    int t=parent[x];
    parent[x]=find(parent[x]);//压缩路径 ,都指向根节点 
    num[x]+=num[t];//每个球移动的次数等于本身移动的个数加上父节点移动的次数
    return parent[x];	 

//	int r=x;
//	while(r!=parent[r])
//	{
//		num[r]+=num[parent[r]]; //num需要通过加上父节点来更新 
//		r=parent[r];						
//	}		
//	int i=x,j;//路径压缩 
//	while(i!=r)
//	{		
//		j=parent[i];
//		parent[i]=r;
//		i=j;
//	}
//	return r;
}

void join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{
		parent[fx]=fy;//把fx的根节点赋予fy,即把城市fx的龙珠给城市移到fy 
		num[fx]=1;//头结点移动一次 
		rank[fy]+=rank[fx];//根节点代表城市 
	}
}

int main()
{
	int t;
	int n,m,a,b;
	int i;
	char ch;
	int cnt=0;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		getchar();
		for(i=1;i<=n;++i)
		{
			parent[i]=i;
			num[i]=0;
			rank[i]=1; 
		}
		int flag=1;
//		printf("Case %d:\n",++cnt);
		while(m--)
		{
			scanf("%c",&ch);
			if(ch=='T')
			{
				scanf("%d%d",&a,&b);
				getchar();
				join(a,b);//把a所在的城市的龙珠调到城市b 
			}
			else if(ch=='Q')
			{
				scanf("%d",&a);
				getchar();
				int temp=find(a); //找龙珠a在哪个城市,在找的时候不停的会加上它的父节点 
				if(flag) {
					printf("Case %d:\n",++cnt);
					flag=0;
				}
				printf("%d %d %d\n",temp,rank[temp],num[a]); 
			} 
		}
	}
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值