uva 10305

/*************************************************************************
     File Name: 10305four.cpp
     Author: yubo
     Mail: yuzibode@126.com 
     Created Time: 2014年06月02日 星期一 00时23分06秒
     学习重点:
reference
John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.

Input

The input will consist of several instances of the problem. Each instance begins with a line containing two integers, 1 <= n <= 100 and m. n is the number of tasks (numbered from 1 to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed before task j. An instance with n = m = 0 will finish the input.

Output
For each instance, print a line with n integers representing the tasks in a possible order of execution.
Sample Input

5 4

1 2

2 3

1 3

1 5

0 0

Sample Output

1 4 2 5 3:
http://sbp810050504.blog.51cto.com/2799422/901022
 ************************************************************************/

#include<cstring>
#include<cstdio>
#include<iostream>
#include<stack>
using namespace std;
#define MAXN 105
//have time according to text to write

struct ArcNode{
	int to;
	struct ArcNode* next;
};
ArcNode* List[MAXN];
int n,m;
int counts[MAXN];
int output[MAXN];
void toposort()
{
stack<int> s;
	memset(output,0,sizeof(output));
	for(int i=0;i<n;i++){
		if(counts[i]==0){

		
			s.push(i);
		}
	}
	bool bcycle=false;
	ArcNode* temp=new ArcNode;
	int k=0;
	for(int i=0;i<n;i++){
		if(s.empty()){
			bcycle=true;
			break;

		}
		else{
			int j=s.top();s.pop();
			output[k++]=j+1;
			temp=List[j];
			while(temp!=NULL){
				int f=temp->to;
				counts[f]--;
				if(counts[f]==0){
					s.push(f);
				}
				temp=temp->next;
			}
		}
	}if(bcycle)
	printf("The Network has a cycle\n");
	else
	{
		for(int l=0;l<n-1;l++)
			printf("%d ",output[l]);
			printf("%d\n",output[n-1]);
	}
}
void del()
{
	ArcNode* temp=new ArcNode;
	for(int i=0;i<n;i++)
	{
		temp=List[i];
		while(temp!=NULL){
			List[i]=temp->next;
			delete temp;
			temp=List[i];
		}

	}

}
int main()
{
	freopen("in.txt","r",stdin);
	int u,v;
	while(scanf("%d%d",&n,&m)){
		if(!n&&!m)
			break;
		memset(List,0,sizeof(List));
		memset(counts,0,sizeof(counts));
		for(int i=0;i<m;i++){
			scanf("%d%d",&u,&v);
			u--;v--;
			counts[v]++;
			ArcNode* temp=new ArcNode;
			temp->to=v;
			temp->next=NULL;
			if(temp==NULL)
				List[u]=temp;
			else{
				temp->next=List[u];
				List[u]=temp;
			}
		}

		ArcNode* temp=new ArcNode;
		toposort();
		del();
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值