vue-devtools在build时出错

前端 专栏收录该内容
31 篇文章 1 订阅

安装vue-devtools时,我最先开始是在https://github.com/vuejs/vue-devtools下载的最新版本(4.1.4)

最开始nodejs版本是6,在cnpm install安装依赖时提示部分依赖可能由于node版本过低无法使用,所以我升级成了8,然后再开始cnpm run build进行编译

但是在编译到91%的时候弹出error:


我再xxxxx\vue-devtools-master\shells\chrome下的manifest.json,已经将 

"background": {

    "scripts": [
      "build/background.js"
    ],
    "persistent": false

  },

改为true

应该不是这个引起的,然后在网上找了一圈没发现解决方法。

最后在release中找到v4.1.3,替换掉原先的内容(node_modules太大所以没动),重新cnpm install(node_modules没动所以很快),然后再build就成功了。

结论:貌似是最新版本问题

4.1.3已编译版本下载地址:https://download.csdn.net/download/yytoo2/10372052(貌似不允许设置0币)

  • 0
    点赞
  • 1
    评论
  • 0
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

©️2021 CSDN 皮肤主题: 技术工厂 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值