内网下解决dependencies的classpath依赖问题

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/yzpbright/article/details/53493714

参考:Could not resolve com.android.tools.build:gradle:0.5.+


原文:

使用Android studio Gradle 打包Android项目遇到 

couldnot resolve com.android.tools.build:gradle:1.3.0 错误,与http://stackoverflow.com/questions/17968960/could-not-resolve-com-android-tools-buildgradle0-5

问题一样,就按照老外的教程解决了问题:


自己也整理一下:

http://www.mvnrepository.com/artifact/com.android.tools.build/builder/1.3.1

打开改地址,只要修改链接后面的版本号就可以看见对应jar包,com.android.tools.build  也就是android 项目的构建工具,在主项目的build.gradle文件里面


buildscript {  
    repositories {  
        jcenter()  
    }  
    dependencies {  
        classpath 'com.android.tools.build:gradle:1.3.0'  
    }  
}  
  
allprojects {  
    repositories {  
        jcenter()  
        mavenLocal()  
        maven { url "https://raw.githubusercontent.com/umeng/mvn-repo-umeng/master/repository" }  
    }  
  
  
    println "In posdevice, gradle id is " + gradle.hashCode()  
    println "Home Dir:" + gradle.gradleHomeDir  
    println "User Home Dir:" + gradle.gradleUserHomeDir  
    println "Parent: " + gradle.parent  
}



可以看到,有可能由于网络问题,对应的版本下不下来,就无法进行打包构建,所有我们就可以使用本地的方式:


我的做法是:

1.下载maven,并配置好环境变量

2.讲对应的jar包放到maven的本地库里面

3.mavenCentral()修改为 mavenLocal()



没有更多推荐了,返回首页