hdoj2141Can you find it?

Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
  
  
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output
  
  
Case 1: NO YES NO
 题意:有三个集合,给一个n,分别从三个集合中抽取一个数,使这三个数的和等于n,问能不能找到这样的三个数.
思路:将这前两个集合(因为害怕超时,所以先忽略第三个集合)中分别抽取的两个数的和的所有情况按从小到大的顺序放入一个数组中,记录长度为k,然后使左边界为0,右边界为k,然后用二分搜索.
代码如下:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
bool cmp(int x,int y)
{
	return x<y;
}
int st1[550],st2[550],st3[550];
int sum[550*550],k;
bool judge(int x)
{
	int l,r,mid;
	l=1,r=k;
	while(l<=r)
	{
		mid=(l+r)>>1;
		if(sum[mid]>x)
		r=mid-1;
		else if(sum[mid]<x)
		l=mid+1;
		else
		return true;
	}
	return false;
}
int main()
{
	int a,b,c,x,t=0;
	while(scanf("%d%d%d",&a,&b,&c)!=EOF)
	{
		int i,j,n,l,r;
		for(i=1;i<=a;i++)
		scanf("%d",&st1[i]);
		for(i=1;i<=b;i++)
		scanf("%d",&st2[i]);
	    k=0;
		for(i=1;i<=a;i++)
		{
			for(j=1;j<=b;j++)
			{	
			    k++;
				sum[k]=st1[i]+st2[j];
			
			}
			
		}
		sort(sum+1,sum+k+1);
		for(i=0;i<c;i++)
		scanf("%d",&st3[i]);
		scanf("%d",&n);
		t++;
		printf("Case %d:\n",t);
		while(n--)
		{
		    scanf("%d",&x);
            bool flag=true;
            for(i=0;i<c;i++)
            {
            	if(judge(x-st3[i]))
            	{
            		printf("YES\n");
            		flag=false;
            	    break;	
				}
            
			}
            if(flag)
            printf("NO\n");
		}
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值