POJ2377(最大生成树)

Description

Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn't even want to pay Bessie. 

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a "tree".

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.

Output

* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.

Sample Input

5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17

Sample Output

42

Hint

OUTPUT DETAILS: 

The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.

给出每条边的端点和权值,使他们生成一个树,且权值之和最大.

思路:先将每条边按权值从大到小排列,然后开始组合,如果两个端点的根节点相同,那么便跳过去.

代码如下:

#include<cstdio> 
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
struct node{
	int u,v,w;
}edge[5000500];
bool cmp(node a,node b)
{
	return a.w>b.w;
}
int n,m,i;
int par[1010],sum=0,ant=0;
void init()
{
	for(i=1;i<=n;i++)
	par[i]=i;
}
int find(int x)
{
	if(x==par[x])
	return x;
	else
	return par[x]=find(par[x]);
}
int unite(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{
		par[fy]=fx;
		return 1;
	}
	return 0;
}

int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		int ans=0;
		ant=0;
		for(i=1;i<=m;i++)
		{
			scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].w);
			
		}
		sort(edge+1,edge+m+1,cmp);
        init();
		for(i=1;i<=m;i++)
		{
			if(unite(edge[i].u,edge[i].v))
			{
				ant++;
				sum+=edge[i].w;
				//printf("%d\n",sum);
			}
			if(ant==n-1)
			break;
		}
		for(i=1;i<=n;i++)
		{
			if(par[i]==i)
			ans++;
		}
		if(ans>1)
		printf("-1\n");
		else
		printf("%d\n",sum);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值