杭电5505GT and numbers(判断一个数通过累乘他的因子是否可以得到另一个数)

GT and numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1793    Accepted Submission(s): 476


Problem Description
You are given two numbers  N  and  M .

Every step you can get a new  N  in the way that multiply  N  by a factor of  N .

Work out how many steps can  N  be equal to  M  at least.

If N can't be to M forever,print  1 .
 

Input
In the first line there is a number  T . T  is the test number.

In the next  T  lines there are two numbers  N  and  M .

T1000 1N1000000 , 1M263 .

Be careful to the range of M.

You'd better print the enter in the last line when you hack others.

You'd better not print space in the last of each line when you hack others.
 

Output
For each test case,output an answer.
 

Sample Input
  
  
3 1 1 1 2 2 4
 

Sample Output
  
  
0 -1 1
 

Source
m的范围太大,不能用long long,应用unsigned long long
#include<stdio.h>
#define LL unsigned long long 
LL gcd(LL a,LL b)
{
return b==0?a:gcd(b,a%b);
}
int main()
{
int t;
LL n,m,l,u;
scanf("%d",&t);
while(t--)
{
scanf("%lld%lld",&n,&m);
if(n>m||m%n)
printf("-1\n");
else if(m==n)
printf("0\n");
else
{
l=0;
int ans=1;
while(n!=m)
{
u=gcd(n,m/n);   求(n,m/n)的最大公约数是为防止8 12这样的情况
if(u==1||n>m)
{
ans=0;
break;
}
l++;
n*=u;
}
if(ans)
printf("%lld\n",l);
else
printf("-1\n");
}
}
return 0;
}
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值