杭电5586 Sum(dp)

Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 676    Accepted Submission(s): 357


Problem Description
There is a number sequence  A1,A2....An ,you can select a interval [l,r] or not,all the numbers  Ai(lir)  will become  f(Ai) . f(x)=(1890x+143)mod10007 .After that,the sum of n numbers should be as much as possible.What is the maximum sum?
 

Input
There are multiple test cases.
First line of each case contains a single integer n. (1n105)
Next line contains n integers  A1,A2....An . (0Ai104)
It's guaranteed that  n106 .
 

Output
For each test case,output the answer in a line.
 

Sample Input
  
  
2 10000 9999 5 1 9999 1 9999 1
 

Sample Output
  
  
19999 22033
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5589  5588  5587  5585  5584 
 
变相的最大字段和,附代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[110000],i,j,k,l,m,n,b[110000],c[110000];
int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		int ans=0;
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			b[i]=(a[i]*1890+143)%10007;
			c[i]=b[i]-a[i];//c数组用来储存差值 
			ans+=a[i];//先求和 
		}
		int sum=0;
		int Max=0;	
		for(i=0;i<n;i++)//最大字段和代码 
		{
			if(sum<=0)
			sum=c[i];
			else
			sum+=c[i];
			Max=max(sum,Max);//找到c数组里边的最大字段和 
		}
		printf("%d\n",Max+ans);//输出结果 
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值