杭电5505 GT and numbers

GT and numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1494    Accepted Submission(s): 376


Problem Description
You are given two numbers  N  and  M .

Every step you can get a new  N  in the way that multiply  N  by a factor of  N .

Work out how many steps can  N  be equal to  M  at least.

If N can't be to M forever,print  1 .
 

Input
In the first line there is a number  T . T  is the test number.

In the next  T  lines there are two numbers  N  and  M .

T1000 1N1000000 , 1M263 .

Be careful to the range of M.

You'd better print the enter in the last line when you hack others.

You'd better not print space in the last of each line when you hack others.
 

Output
For each test case,output an answer.
 

Sample Input
  
  
3 1 1 1 2 2 4
 

Sample Output
  
  
0 -1 1
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5589  5588  5587  5584  5583 
 

欧几里得辗转相除法,求得最大公约数,题意为n乘以n的因子,问最少乘多少次才能乘到m,n乘完以后就会更新,变为新的n:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
unsigned long long  i,j,k,l,m,n,help;//2^63已超过long long,需要+unsigned  
int gcd(unsigned long long m,unsigned long long  n)//欧几里得算法,求最大公约数 
{
	help=1;
	while(help!=0)//辗转相除法 
	{
		help=m%n;
		m=n;
		n=help;
	}
	return m;
 } 
int main()
{
	scanf("%I64d",&k);
	while(k--)
	{
		int flag=0;
		scanf("%I64d%I64d",&n,&m);
		if(m<n||m%n||n==0)
		flag=1;
		if(flag==1)//这里一定要先判断,否则就会出现除0的情况 
		{
			printf("-1\n");
			continue;
		}
		if(n==m)//相等时 输出0 
		{
			printf("0\n");
			continue;
		}
		int ans=0;
		while(n!=m)
		{
			if(gcd(m/n,n)==1)//如果最大公约数为1 
			{
				flag=1;//则永远也不可能达到 
				break;
			}
			n=n*(gcd(m/n,n));//如果不为1,就让n乘以m/n的最大公约数 
			ans++;
		}
		if(flag==0)
		printf("%d\n",ans);
		else
		printf("-1\n");
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值