杭电5655 CA Loves Stick

CA Loves Stick

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 695    Accepted Submission(s): 245


Problem Description
CA loves to play with sticks.
One day he receives four pieces of sticks, he wants to know these sticks can spell a quadrilateral.
(What is quadrilateral? Click here: https://en.wikipedia.org/wiki/Quadrilateral)
 

Input
First line contains  T  denoting the number of testcases.
T  testcases follow. Each testcase contains four integers  a,b,c,d  in a line, denoting the length of sticks.
1T1000, 0a,b,c,d2631
 

Output
For each testcase, if these sticks can spell a quadrilateral, output "Yes"; otherwise, output "No" (without the quotation marks).
 

Sample Input
  
  
2 1 1 1 1 1 1 9 2
 

Sample Output
  
  
Yes No
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5659  5658  5657  5656  5654 
 
判断给的4条长度能不能构成一个四边形,也就是说最长的一条边的长度是不是小与其他三条边的长度和,由于数据太大,所以要用unsigned 和一个减法:
本想用除法的但是这样不是很对:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
unsigned __int64 a[5],i,j,k,l,m,n;
int main()
{
	int p;
	scanf("%d",&p);
	while(p--)
	{
		for(i=0;i<4;i++)
		scanf("%I64d",&a[i]);
		sort(a,a+4);
		if(a[0]==0)
		{
			printf("No\n");
			continue;
		}
		if(a[0]+a[1]>a[3]-a[2])
		printf("Yes\n");
		else
		printf("No\n");
		//double help=a[1]*1.00/4+a[2]*1.00/4+a[0]*1.00/4;
		//double cnt=a[3]*1.00/4;
		
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值