杭电5522Numbers

Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/262144 K (Java/Others)
Total Submission(s): 1123    Accepted Submission(s): 614


Problem Description
There are n numbers  A1,A2....An ,your task is to check whether there exists there different positive integers i, j, k ( 1i,j,kn ) such that  AiAj=Ak
 

Input
There are multiple test cases, no more than 1000 cases.
First line of each case contains a single integer n. (3n100) .
Next line contains n integers  A1,A2....An . (0Ai1000)
 

Output
For each case output "YES" in a single line if you find such i, j, k, otherwise output "NO".
 

Sample Input
  
  
3 3 1 2 3 1 0 2 4 1 1 0 2
 

Sample Output
  
  
YES NO YES
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5659  5658  5657  5656  5654 
这里贴一个o(n2)的代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[11000],i,j,k,l,m,n,p,b[11000],vist[11000];
int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		memset(vist,0,sizeof(vist)); 
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			vist[a[i]]++;
		}
		sort(a,a+n);
		int cnt=0;
		for(i=0;i<n;i++)
		for(j=i+1;j<n;j++)
		{
			vist[a[i]]--;
			vist[a[j]]--;
			if(vist[a[i]+a[j]])
			cnt=1;
			vist[a[i]]++;
			vist[a[j]]++;
		}
		if(cnt)
		printf("YES\n");
		else
		printf("NO\n");
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值