杭电5538House Building

House Building

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 594    Accepted Submission(s): 381


Problem Description
Have you ever played the video game Minecraft? This game has been one of the world's most popular game in recent years. The world of Minecraft is made up of lots of  1×1×1  blocks in a 3D map. Blocks are the basic units of structure in Minecraft, there are many types of blocks. A block can either be a clay, dirt, water, wood, air, ... or even a building material such as brick or concrete in this game.


Figure 1: A typical world in Minecraft.


Nyanko-san is one of the diehard fans of the game, what he loves most is to build monumental houses in the world of the game. One day, he found a flat ground in some place. Yes, a super flat ground without any roughness, it's really a lovely place to build houses on it. Nyanko-san decided to build on a  n×m  big flat ground, so he drew a blueprint of his house, and found some building materials to build.

While everything seems goes smoothly, something wrong happened. Nyanko-san found out he had forgotten to prepare glass elements, which is a important element to decorate his house. Now Nyanko-san gives you his blueprint of house and asking for your help. Your job is quite easy, collecting a sufficient number of the glass unit for building his house. But first, you have to calculate how many units of glass should be collected.

There are  n  rows and  m  columns on the ground, an intersection of a row and a column is a  1×1  square,and a square is a valid place for players to put blocks on. And to simplify this problem, Nynako-san's blueprint can be represented as an integer array  ci,j(1in,1jm) . Which  ci,j  indicates the height of his house on the square of  i -th row and  j -th column. The number of glass unit that you need to collect is equal to the surface area of Nyanko-san's house(exclude the face adjacent to the ground).
 

Input
The first line contains an integer  T  indicating the total number of test cases.
First line of each test case is a line with two integers  n,m .
The  n  lines that follow describe the array of Nyanko-san's blueprint, the  i -th of these lines has  m  integers  ci,1,ci,2,...,ci,m , separated by a single space.

1T50
1n,m50
0ci,j1000
 

Output
For each test case, please output the number of glass units you need to collect to meet Nyanko-san's requirement in one line.
 

Sample Input
  
  
2 3 3 1 0 0 3 1 2 1 1 0 3 3 1 0 1 0 0 0 1 0 1
 

Sample Output
  
  
30 20
Figure 2: A top view and side view image for sample test case 1.
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5659  5658  5657  5656  5654 
 
亚洲区的题,说的是,先给一个矩阵,然后矩阵上边是楼的高度,求用刷子把这些楼都刷漆,需要刷的面积,底部不刷,拿第二组测试数据,四个1 不相邻,每个需要刷5个面积,就输出了20:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int map[110][110],i,j,k,l,m,n,p;
__int64 ans;
int main()
{
	scanf("%d",&p);
	while(p--)
	{
		scanf("%d%d",&m,&n);
		memset(map,0,sizeof(map));
		__int64 help=0;
		ans=0;
		for(i=0;i<m;i++)
		for(j=0;j<n;j++)
		{
			scanf("%d",&map[i][j]);
			ans+=map[i][j];
		}
		ans*=6;//每个表面积都是6  
		
		for(i=0;i<m;i++)
		for(j=0;j<n;j++)
		{
			if(map[i][j+1]&&map[i][j]!=0)//找跟当前楼右边相邻的比较那个小,就表示重叠了多少 
			ans-=min(map[i][j+1],map[i][j])*2;
			
			
			
			if(map[i+1][j]&&map[i][j]!=0)//找当前的下边的 
			ans-=min(map[i+1][j],map[i][j])*2;
			
			
			
			if(map[i][j])
			ans-=((map[i][j]-1)*2+1);
			
			
		}
		
		
		 printf("%I64d\n",ans);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值