mac上更新ruby

因为准备在项目中使用bootstrap,在安装bootstrap过程中提示需要Ruby的版本在1.9.2以上,而目前使用的Ruby版本是Mac系统自带的1.8.7。所以需要对Ruby进行升级。这里使用RVM对Ruby进行升级,升级过程如下:

1、安装 RVM

RVM:Ruby Version Manager,Ruby版本管理器,包括Ruby的版本管理和Gem库管理(gemset)


[ruby] view plain copy


  1. $ curl -L get.rvm.io | bash -s stable  


等待一段时间后就可以成功安装好 RVM。


[ruby] view plain copy


  1. $ source ~/.bashrc  
  2. $ source ~/.bash_profile  


测试是否安装正常


[ruby] view plain copy


  1. rvm -v  


2、用RVM升级Ruby


[ruby] view plain copy


  1. #查看当前ruby版本  
  2. $ ruby -v  
  3. ruby 1.8.7  
  4. #列出已知的ruby版本  
  5. $ rvm list known  
  6. #安装ruby 1.9.3  
  7. $ rvm install 1.9.3  


安装完成之后ruby -v查看是否安装成功。

阅读更多
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭