POJ3069 贪心法 覆盖问题

Saruman's Army
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6197 Accepted: 3165

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4


遇到的问题和解决思路:

       个人感觉,这道题如果没有先看过书再写的话,肯定不会想到这个是贪心法,而且也不好描述。因为要同时左右都考虑到,所以要既考虑到右边,也考虑到左边。

       具体的解决思路就看代码吧,虽然AC了,不过自己编写还是和书上有点不一样的。(挑战p46)


给出代码:


#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>

using namespace std;

int r,n;
int di[1005];

void solve(){
	int res = 0;
	sort(di ,di + n);
	for(int i = 0;i < n; i++){
		int a = di[i];
		while(a + r >= di[i] && i < n) i++;
		a = di[--i];//书上这里是 a = di[i-1];
		while(a + r >= di[i] && i < n)i++;//感觉这一步的i<n绝对不能少,不然超出范围了,di[i]就是随机的一个数字了
		res++;
		i--;//书上没有这一步。之所以这一步和书上有区别,是因为书上用的是while(i<n),然而我这里用的是i++
	}
	printf("%d\n",res);
}

int main(){
	while(scanf("%d%d",&r,&n)!=EOF){
		if(r == -1 && n == -1)break;
		memset(di , 0 ,sizeof(di));
		for(int i = 0;i < n ; i++)scanf("%d",&di[i]);
		solve();
		
	}
	return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值