易语言大漠多线程启动线程传参数组传参

多线程传参-数组传参

1、传递数组变量
2、取变量数据地址()
3、等待线程()
源码:

.版本 2
.支持库 EThread
.支持库 spec
 
.局部变量 n
 
编辑框1.内容 = “”
.计次循环首 (200, n)
    文本数组 [n] = “编号--” + 到文本 (n)
    启动线程 (&子程序1, 取变量数据地址 (文本数组 [n]), t)
    等待线程 (t, 10)
 
.计次循环尾 ()
 
.子程序 子程序1
.参数 a_address, 整数型
.局部变量 str, 文本型
 
str = 指针到文本 (a_address)
' 调试输出 (str)
编辑框1.加入文本 (str + #换行符)
 
.子程序 __启动窗口_将被销毁
 
关闭线程句柄 (t)

511遇见易语言多线程大漠多线程

 

©️2020 CSDN 皮肤主题: 撸撸猫 设计师: 设计师小姐姐 返回首页
实付0元
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值