511遇见易语言API模块制作PathFindFileName文件取文件名

PathFindFileName函数,函数的作用是返回路径中的文件名,是shlwapi.dll里的一个函数。 PathFindFileName的兼容性确实好,比如PathFindFileName在后期的WINDOWS上支持“/”作为路径分隔符,甚至可以混用,如:c:\windows/system32/kernel32.dll

易语言PathFindFileNameA获取路径文件名

视频链接:

511遇见易语言模块API教程

API --PathFindFileName

.版本 2

.DLL命令 PathFindFileNameA, 文本型, "shlwapi.dll", "PathFindFileNameA", , 文件_取文件名
.参数 pszPath, 文本型, , 文件完整路径

视频教程模块源码

.版本 2

.子程序 文件_取文件名, 文本型, 公开, 比如:F:\123.txt,成功返回123,失败返回空
.参数 路径文件名, 文本型, , 文件的完整路径包括名称
.参数 是否带后缀, 逻辑型, 可空, 默认为假,不带后缀,参数为真带后缀
.局部变量 j_fname, 文本型

j_fname = PathFindFileNameA (路径文件名)
.如果真 (取文本右边 (j_fname, 1) = “\”)
返回 (“”)
.如果真结束
返回 (选择 (是否带后缀, j_fname, 取文本左边 (j_fname, 取文本长度 (j_fname) - 取文本长度 (文件_取扩展名 (j_fname)))))

易语言调用源码:

.版本 2

.程序集 窗口程序集_启动窗口, , , 511遇见(www.511yj.com)

.子程序 _按钮1_被单击, , , 文件_取文件名
.局部变量 f_name, 文本型

f_name = 文件_取文件名 (“C:\Users\zcp\Desktop\易语言模块API-31\511遇见模块模块源码.e”, )
标签1.标题 = f_name

 

源码:511遇见易语言模块API制作

          易语言API模块制作文件取文件名

         易语言模块API制作系列视频教程

展开阅读全文
©️2020 CSDN 皮肤主题: 撸撸猫 设计师: 设计师小姐姐 返回首页
实付0元
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值