易语言教程数据库添加复制结构置当前库

易语言 专栏收录该内容
409 篇文章 11 订阅

本课重点讲解了易语言数据库的命令 添加()、复制结构(),全部关闭 ()、清空(),置当前库( )命令。特别注意,这里的添加()并不是在一个数据库的尾部追加记录,而是把一个数据库的记录添加的另外一个数据库,可以理解为复制一部分记录。

“添加()”,可以将其它数据库内的记录添加到本数据库。
“复制结构( )”
“置当前库( )”
“全部关闭 ( )”
“清空()”

视频链接:

511遇见易语言教程数据库

教程源码:

 

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击, , , 复制结构

打开 (“成绩.edb”, , , , , , )
.如果 (复制结构 (“成绩2.edb”, ) = 真)
    信息框 (“复制数据库 成绩2.edb 成功!”, 0, , )
.否则
    信息框 (“复制数据库 成绩2.edb 失败!”, 0, , )
.如果结束


.子程序 _按钮2_被单击, , , 打开所有数据库

打开 (取运行目录 () + “\成绩.edb”, , , , , , )
打开 (取运行目录 () + “\成绩2.edb”, , , , , , )
' 准备往 成绩2.edb 这个数据库 添加记录“
置当前库 (取运行目录 () + “\成绩2.edb”)

.子程序 __启动窗口_将被销毁

全部关闭 ()

.子程序 _按钮3_被单击, , , 给新数据库添加记录
.局部变量 a, 整数型
.局部变量 n, 整数型

.判断开始 (编辑框1.内容 ≠ “”)
    a = 到整数 (删首尾空 (编辑框1.内容))
    ' 添加 是第一个数据库 成绩.edb 里的数据 到 成绩2.edb
    清空数据库内容 ()
    .如果 (添加 (取运行目录 () + “\成绩.edb”, 到整数 (读 (“语文”)) > a, ) = 真)
        列表框1.清空 ()
        到首记录 ()
        .计次循环首 (取记录数 (), n)
            列表框1.加入项目 (到文本 (n) + “  ” + 读 (“姓名”) + “  ” + 读 (“语文”), )
            跳过 ()
        .计次循环尾 ()

    .否则
        信息框 (“添加失败!”, 0, , )
    .如果结束

.默认
    信息框 (“请在编辑框中输入添加查询成绩的条件”, 0, , )
.判断结束


.子程序 _按钮4_被单击, , , 清空第二个数据库

清空数据库内容 ()

.子程序 清空数据库内容

打开 (取运行目录 () + “\成绩2.edb”, , , , , , )
置当前库 (取运行目录 () + “\成绩2.edb”)
清空 ()

.子程序 _按钮5_被单击
.局部变量 n, 整数型

置当前库 (取运行目录 () + “\成绩.edb”)
列表框1.清空 ()
到首记录 ()
.计次循环首 (取记录数 (), n)

    列表框1.加入项目 (到文本 (n) + “  ” + 读 (“姓名”) + “  ” + 读 (“语文”), )
    跳过 ()
.计次循环尾 ()

源码:511遇见易语言教程

           511遇见易语言教程视频链接

           511遇见易语言教程数据库-添加

  • 0
    点赞
  • 0
    评论
  • 0
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

©️2021 CSDN 皮肤主题: 酷酷鲨 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值