POJ-3274-Gold Balanced Lineup

Gold Balanced Lineup
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 14378 Accepted: 4165

Description

Farmer John's N cows (1 ≤ N ≤ 100,000) share many similarities. In fact, FJ has been able to narrow down the list of features shared by his cows to a list of only K different features (1 ≤ K ≤ 30). For example, cows exhibiting feature #1 might have spots, cows exhibiting feature #2 might prefer C to Pascal, and so on.

FJ has even devised a concise way to describe each cow in terms of its "feature ID", a single K-bit integer whose binary representation tells us the set of features exhibited by the cow. As an example, suppose a cow has feature ID = 13. Since 13 written in binary is 1101, this means our cow exhibits features 1, 3, and 4 (reading right to left), but not feature 2. More generally, we find a 1 in the 2^(i-1) place if a cow exhibits feature i.

Always the sensitive fellow, FJ lined up cows 1..N in a long row and noticed that certain ranges of cows are somewhat "balanced" in terms of the features the exhibit. A contiguous range of cows i..j is balanced if each of the K possible features is exhibited by the same number of cows in the range. FJ is curious as to the size of the largest balanced range of cows. See if you can determine it.

Input

Line 1: Two space-separated integers,  N and  K.
Lines 2.. N+1: Line  i+1 contains a single  K-bit integer specifying the features present in cow  i. The least-significant bit of this integer is 1 if the cow exhibits feature #1, and the most-significant bit is 1 if the cow exhibits feature # K.

Output

Line 1: A single integer giving the size of the largest contiguous balanced group of cows.

Sample Input

7 3
7
6
7
2
1
4
2

Sample Output

4

Hint

In the range from cow #3 to cow #6 (of size 4), each feature appears in exactly 2 cows in this range


参考:   http://www.cnblogs.com/lyy289065406/archive/2011/07/30/2122224.html
求最远的两行间各个特征出现次数相等”即“求最远的相同两行"

以样例为例

7 3
7
6
7
2
1
4
2
 

先把7个十进制特征数转换为二进制,存放到特征数组Map[ ][ ],得到:

7   1 1 1

6   1 1 0

7   1 1 1

2   0 1 0

1   0 0 1

4   1 0 0 

2   0 1 0

逐行累加得

1 1 1

2 2 1

3 3 2

3 4 2

3 4 3

4 4 3

4 5 3

所有列都减去第一列

0 0 0

0 0 -1

0 0 -1

0 1 -1

0 1 0

0 0 -1

0 1 -1

显然第2行与第6行相等,均为0 0 -1,且距离最远,距离为6-2=4,这就是所求。

 用hash来存放

有一个坑是如果有某一行 全为零,那么从第一行到这一行的变化量也是0


#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<queue>
#include<vector>
#include<algorithm>
using namespace std;
const int MAXN = 100005;
const int MAXK = 35;
const int mod = 100007;
int Map[MAXN][MAXK];
int n ,k;
vector<int>qq[mod+5];
bool f(int p1, int p2)
{
    for(int i = 1; i<=k; ++i)
    {
     if(Map[p1][i]!=Map[p2][i])
        return false;
    }
    return true;
}
int main()
{
    int x;
    scanf("%d%d", &n,&k);
    for(int i = 1;i<=n;++i)
    {
        scanf("%d",&x);
        for(int j = 1; j<=k;++j)
        {
            Map[i][j] = x%2;
            x/=2;
            if(i>1)Map[i][j]+=Map[i-1][j];
            if(j>1)Map[i][j]-=Map[i][1];
        }
        Map[i][1] = 0;
    }
    int l = mod+1, r = -1, t, MAX = 0, sum;
    for(int i = 1; i<=n;++i)
    {
         t = sum = 0;
        for(int j = 1; j<=k;++j)
          {
              sum = (sum+Map[i][j]+mod)%mod;
              if(!Map[i][j])++t;
          }
        if(sum<0)sum*=-1;
        if(t==k&&i>MAX)MAX = i;
        qq[sum].push_back(i);
        if(sum<l)l = sum;
        if(sum>r)r = sum;
    }
    for(int i = l; i<=r; ++i)
    {
        for(int j = 0; j<(int)qq[i].size();++j)
        {
            for(int kk = j+1; kk<(int)qq[i].size();++kk)
            {
                int p1 = qq[i][j], p2=qq[i][kk];
                if(f(p1,p2)&&MAX<(int)fabs(p2-p1))
                    MAX=(int)fabs(p2-p1);
            }
        }
    }
    printf("%d\n",MAX);
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值