杭电 ACM 1.2.4

Balloon Comes!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2653 Accepted Submission(s): 869
 
Problem Description
The contest starts now! How excited it is to see balloons floating around. You, one of the best programmers in HDU, can get a very beautiful balloon if only you have solved the very very very... easy problem.
Give you an operator (+,-,*, / --denoting addition, subtraction, multiplication, division respectively) and two positive integers, your task is to output the result.
Is it very easy?
Come on, guy! PLMM will send you a beautiful Balloon right now!
Good Luck!
 
Input
Input contains multiple test cases. The first line of the input is a single integer T (0<T<1000) which is the number of test cases. T test cases follow. Each test case contains a char C (+,-,*, /) and two integers A and B(0<A,B<10000).Of course, we all know that A and B are operands and C is an operator.
 
Output
For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.
 
Sample Input
4
+ 1 2
- 1 2
* 1 2
/ 1 2
 
Sample Output
3
-1
2
0.50
 
Author
lcy

这题并不是很难,但是我第一次却没有A过去,而是得了个RA,原因很简单,是因为,当操作符为除号的时候,我没有做判断,到底是否可以除得尽,根据题目要求的是,只有结果不是整数的时候才要求结果精确到小数点后两位,郁闷,细节也很重要啊,提醒自己一下……切记,仔细读题

源代码:

#include<stdio.h>
int main(void)
{
    int n;
    int i;
    int a, b;
    char ch;
    scanf("%d", &n);
    getchar();
    for(i = 0;i < n;i++)
    {
        scanf("%c", &ch);
        getchar();
        scanf("%d", &a);
        getchar();
        scanf("%d", &b);
        getchar();
        switch(ch)
        {
        case '+':
            printf("%d\n", a + b);
            break;
        case '-':
            printf("%d\n", a - b);
            break;
        case '*':
            printf("%ld\n", (long)a * (long)b);
            break;
        case '/':
            if(a % b == 0)
                printf("%d\n", a / b);
            else
                printf("%0.2f\n", (double)a / (double)b);
            break;
        }
    }

    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值