PAT甲级1001 A+B Format (sprintf?)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991
#include <stdio.h>
#include <string.h>
int main()
{
    int a,b;
    scanf("%d%d",&a,&b);
    int c=a+b;
    if (c<0)
    {
         printf("-");
         c=-c;
    }
    char str[11];   //小于11使用sprintf  gcc会有警告?
    sprintf(str,"%d",c);
    int len = strlen(str);
    int r = len%3;      //计算余数,如果余数不为0先输出前几位
    int i=0;            //字符串指针
    for(;i<r;i++)       //输出前面1位或2位
        printf("%c",str[i]);
    if(r!=0 && i<len)   //如果余数不为0并且没有输出完输出,
        printf(",");
    while(i<len)        //循环输出剩下的
    { 
        for (int j=0;j<3;j++)
            printf("%c",str[i++]);
        if (i<len)
            printf(",");
    }
}

 

  • 5
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值