hdoj 1856 more is better (如何记录节点数)

  题目                :http://acm.hdu.edu.cn/showproblem.php?pid=1856

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 19180    Accepted Submission(s): 7054


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex,  the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
 

Sample Input
  
  
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
  
  
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
 

<span style="font-size:14px;">#include<stdio.h>
#include<algorithm>
using namespace std;
int a,b;
int per[10000010];
int n,num[10000010];
int inf;
void init()
{
	for(int i=1;i<=1000000;i++)   //开数组的时候要注意尾标不能大于等于数组长度 
	{
		per[i]=i;
		num[i]=1;  //初始化每个根节点的数量都是1 
	}
}

/*int find(int x){ //路径压缩迭代版本  
    int r = x;  
    while(r!=per[r])   
        r = per[r];//肇东根节点  
    while(x!=r){ //将这棵树上的节点都指向根节点  
        int tmp = per[x];  
       per[x] = r;  
        x= tmp;  
    }  
    return r;  
}*/ 

int find(int x)
{
	if(x==per[x])
	return x;
	else
	return per[x]=find(per[x]);
}
int join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{
		per[fx]=fy;
		num[fy]+=num[fx];  //记录根节点的上节点数量,总把子节点的数量加在父节点上		
	}
	if(num[fy]>inf) 
	inf=num[fy];   //不断保存父节点的节点数最大值 
}
int main()
{
	int i;
	while(scanf("%d",&n)!=EOF)
	{
		init();
		inf=1;
		for(i=1;i<=n;i++)		
	   {
	   		scanf("%d%d",&a,&b);
	   		join(a,b);
	   }
	   
		printf("%d\n",inf);
		
	}
}</span>


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值