Power Strings POJ - 2406 (KMP扩展—next数组应用)

                                  Power Strings     POJ - 2406 

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题意:给定一个字符串,问里面是由多少个相同的子串构成的

思路:KMP的扩展—next数组应用,以下是参考大神的

 AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<utility>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<stack>
#define maxn1 1000005
#define maxn2 10005
#define INF 0x3f3f3f3f
#define LL long long
#define ULL unsigned long long
#define E 1e-8
#define mod 1000000007
#define P pair<int,int>
using namespace std;
 
char str[1000001];
int next[1000001];
int GetNexts(){
    int j=0,k=-1;
    next[0]=-1;
    int len=strlen(str);
    while(j<len){
        if(k==-1||str[j]==str[k]){
            j++;
            k++;
            next[j]=k;
        }
        else k=next[k];
    }
    int s=len-k;
    if(len%s==0){
        return len/s;
    }
    return 1;
}
int main(){
    while(gets(str)){
        if(str[0]=='.')break;
        printf("%d\n",GetNexts());
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值