A Simple Problem with Integers POJ - 3468(线段树-区间更新模板题)

A Simple Problem with Integers

 POJ - 3468

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

题意:区间更新,区间查询

思路:线段树

AC代码(c++ac,g++ TL):

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<utility>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<stack>
#define maxn 100005
#define INF 0x3f3f3f3f
#define LL long long
#define ULL unsigned long long
#define E 1e-8
#define mod 1000000007
#define P pair<int,int>
#define MID(l,r) (l+(r-l)/2)
#define lson(o) (o<<1)
#define rson(o) (o<<1|1)
using namespace std;

LL a[maxn];
struct node{
    int l,r;
    LL sum,inc;
}tree[maxn<<2];
void build(int o,int l,int r)
{
    tree[o].l = l;
    tree[o].r = r;
    tree[o].inc = 0;
    if(l == r){
        tree[o].sum = a[l];
        return ;
    }
    int m = MID(l,r);
    int  lc = lson(o),rc = rson(o);
    build(lc,l,m);
    build(rc,m+1,r);
    tree[o].sum = tree[lc].sum+tree[rc].sum;
}
void update(int o,int l,int r,LL val)
{
    if(tree[o].l == l && tree[o].r == r){
        tree[o].inc += val;
        return ;
    }
    tree[o].sum += val*(r-l+1);
    int m = MID(tree[o].l,tree[o].r);
    int lc = lson(o),rc = rson(o);
    if(r<=m) update(lc,l,r,val);
    else if(l>m) update(rc,l,r,val);
    else{
        update(lc,l,m,val);
        update(rc,m+1,r,val);
    }
}
LL ans_sum;
LL query(int o,int l,int r)
{
    if(tree[o].l == l && tree[o].r == r){
        return tree[o].sum + tree[o].inc *(r-l+1);
    }
    tree[o].sum += (tree[o].r-tree[o].l+1)*tree[o].inc;
    int m = MID(tree[o].l,tree[o].r);
    int lc = lson(o),rc = rson(o);
    update(lc,tree[o].l,m,tree[o].inc);
    update(rc,m+1,tree[o].r,tree[o].inc);  //只更新到下一层
    tree[o].inc = 0;  //清除标记
    if(r<=m) ans_sum = query(lc,l,r);
    else if(l>m) ans_sum = query(rc,l,r);
    else{
        ans_sum = query(lc,l,m)+query(rc,m+1,r);
    }
    return ans_sum;
}
int main()
{
    int n,m,x,y;
    LL t;
    char c;
    while(scanf("%d %d",&n,&m)!=EOF){
        for(int i=1;i<=n;++i){
            scanf("%lld",&a[i]);
        }
        build(1,1,n);
        while(m--){
            cin>>c>>x>>y;
            if(c == 'Q'){
                ans_sum = 0;
                printf("%lld\n",query(1,x,y));
            }
            else{
                cin>>t;
                update(1,x,y,t);
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值