vs2013+ef+orcale更新数据库模型

版权声明:本文为博主原创文章,遵循 CC 4.0 by-sa 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/zhangxiaomin1992/article/details/50538257

vs2013+ef+更新数据库模型时报错:遇到类型为:sysytem.argumentException的异常,异常消息为:无法将运行时连接字符串转换为设计时等效项。

网上查了很多资料,都说换低版本的vs。折腾了好久找到了解决办法。

首先确保连接字符串正确。

请注意C:\Windows\Microsoft.NET\Framework\v4.0.30319\Config下machine.config下的这句话:<add name="ODP.NET, Managed Driver" invariant="Oracle.ManagedDataAccess.Client" description="Oracle Data Provider for .NET, Managed Driver" type="Oracle.ManagedDataAccess.Client.OracleClientFactory, Oracle.ManagedDataAccess, Version=4.121.1.0, Culture=neutral, PublicKeyToken=89b483f429c47342" />注意其中的“invariant="Oracle.ManagedDataAccess.Client”这段,Invariant的意思是相当于在VS2010的开发环境中配置了别名Oracle.ManagedDataAccess.Client,所以你如果没有安装Oracle Data Provider For .Net或者该处的invariant与连接字符串中的provider名字不一样,你就会出现上面的这个错。经过仔细的对比,我发现我的webconfig中一开始provider名字确实和machine.config中的不一样,我把它改成一模一样,然后就成了,不报任何错了。

报错:指定的存储区提供程序在配置中找不到,或者无效

ODTwithODAC112030(Oracle连接VS安装包)  安装。



展开阅读全文

没有更多推荐了,返回首页