安装ubuntu 12.04 server版

版权声明:本文为博主原创文章,遵循 CC 4.0 by-sa 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/zhangzhenhu/article/details/7759668

由于需求,需要再一台服务器上安装一个server版linux,选择了ubuntu 12.04 server。服务器还木有显卡,不得拆下我工作机的显卡救急。


采用u盘安装,用UltraISO把下载的ISO烧录到u盘,然后到/syslinux/目录下,找到了syslinux.cfg,打开后把default vesamenu.c32这一行注释掉。


以上步骤和网上流传的一样,没啥问题。

进入安装界面后,在 加载 光盘基本组件 这一步失败,

解决方法:

把iso镜像 挂载到/cdrom 即可,也就说你要把ubuntu 的iso镜像拷贝到u盘备用。

命令 :

mount /dev/[u盘设备]  /var/usb   先把u盘挂载到任意目录

mount /var/usb/ubuntu.iso /cdrom

这样我的问题就解决了。

安装好后,我要安装gnome桌面,就执行 sudo apt-get install gnome

乱码问题:

由于安装系统的选的中文环境,所以安好后会乱码,未安装gnome前的 shell下也是乱码,安好gnome,gnome下也是他妈乱码。

gnome下汉子其实都是方格,一般这种情况下是缺少 字体

解决方法:

网上方法都是去找系统设置->语言支持,可是我的根本木有,安装; sudo apt-get install  language-selector


展开阅读全文

ubuntu 12.04安装gcc4.1的问题

07-14

请教一个ubuntu 12.04下安装gcc4.1的问题rnrn背景:由于ubuntu12.04默认使用的是gcc4.6,软件需要gcc4.1,因此要自己安装rnrn尝试了几种方法,均遇到了问题,现把问题列出,烦请各位帮忙解决,先谢过。rnrn1. 尝试一:rnrn手动下载cpp-4.1_4.1.2-27ubuntu1_i386.deb/g++-4.1_4.1.2-27ubuntu1_i386.deb/rngcc-4.1_4.1.2-27ubuntu1_i386.deb/gcc-4.1-base_4.1.2-27ubuntu1_i386.deb/rnlibstdc++6-4.1-dev_4.1.2-27ubuntu1_i386.deb 这几个deb文件rnrn使用dpkg -i *.deb安装,出现以下错误:rnrn正在设置 gcc-4.1-base (4.1.2-27ubuntu1) ...rn正在设置 cpp-4.1 (4.1.2-27ubuntu1) ...rn正在处理用于 man-db 的触发器...rndpkg:依赖关系问题使得 gcc-4.1 的配置工作不能继续:rn libgomp1 (4.6.3-1ubuntu5)破坏 gcc-4.1 并且 已安装。rn libstdc++6 (4.6.3-1ubuntu5)破坏 gcc-4.1 并且 已安装。rn libgcc1 (1:4.6.3-1ubuntu5)破坏 gcc-4.1 并且 已安装。rndpkg:处理 gcc-4.1 (--install)时出错:rn 依赖关系问题 - 仍未被配置rndpkg:依赖关系问题使得 g++-4.1 的配置工作不能继续:rn g++-4.1 依赖于 gcc-4.1 (= 4.1.2-27ubuntu1);然而:rn 软件包 gcc-4.1 尚未配置。rndpkg:处理 g++-4.1 (--install)时出错:rn 依赖关系问题 - 仍未被配置rndpkg:依赖关系问题使得 libstdc++6-4.1-dev 的配置工作不能继续:rn libstdc++6-4.1-dev 依赖于 g++-4.1 (= 4.1.2-27ubuntu1);然而:rn 软件包 g++-4.1 尚未配置。rndpkg:处理 libstdc++6-4.1-dev (--install)时出错:rn 依赖关系问题 - 仍未被配置rn在处理时有错误发生:rn gcc-4.1rn g++-4.1rn libstdc++6-4.1-devrnrn-------------rn注:我用过aptitude命令来解除依赖关系,但是没有成功。尝试卸载libstdc++6——4.rn6.3,但是好像目前有挺多软件要使用std。rn-------------rnrn2. 尝试二:rnrn改source.list,直接apt-get install gcc-4.1 gcc-4.1-multilib libstdc++6-4.1-rndevrnrn出现以下问题:rnrn**@ubuntu:/etc/apt$ sudo apt-get install gcc-4.1 gcc-4.1-multilib libstdc++6-rn4.1-devrn正在读取软件包列表... 完成rn正在分析软件包的依赖关系树 rn正在读取状态信息... 完成 rn有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是rn因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件rn包尚未被创建或是它们已被从新到(Incoming)目录移出。rn下列信息可能会对解决问题有所帮助:rnrn下列软件包有未满足的依赖关系:rn gcc-4.1 : 依赖: cpp-4.1 (= 4.1.2-27ubuntu1) 但是它将不会被安装rn 依赖: binutils (>= 2.17cvs20070426) 但是它将不会被安装rn 依赖: libgcc1 (>= 1:4.1.2-27ubuntu1) 但是它将不会被安装rn 依赖: libc6 (>= 2.7) 但是它将不会被安装rn 推荐: libc6-dev (>= 2.5) 但是它将不会被安装rn gcc-4.1-multilib : 依赖: libc6-dev-amd64 但是它将不会被安装rn 依赖: lib64gcc1 (>= 1:4.1.2-27ubuntu1) 但是它将不会被安装rn libstdc++6-4.1-dev : 依赖: g++-4.1 (= 4.1.2-27ubuntu1) 但是它将不会被安装rn 依赖: libstdc++6 (>= 4.1.2-27ubuntu1) 但是它将不会被安rn装rn 依赖: libc6-dev (>= 2.5) 但是它将不会被安装rnE: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关rn系。rnrn-------------rn注:这个网上不少人说是源的问题,但是换过几个源之后仍没有解决。感觉还是跟之前rn“存在依赖关系”的问题类似,不知道是哪处设置的问题。rn-------------rnrn麻烦了解的大侠帮忙解答以下,谢谢! 论坛

[求助]Ubuntu 12.04安装Eclipse-CDT

06-12

虚拟机 Ubuntu 12.04;rn已经安装好Eclipse platform了,也已经安装好pde 和 jdt。rn打开Eclipse 不能建立 C/C++ 的project;rnrn安装dct : $ sudo apt-get install eclipse-cdt rnrn[color=#FF0000]输出结果:[/color]rnrn正在读取软件包列表... 完成rn正在分析软件包的依赖关系树 rn正在读取状态信息... 完成 rn将会安装下列额外的软件包:rn eclipse-cdt-jni eclipse-emf eclipse-rse libcommons-net2-javarn建议安装的软件包:rn libcommons-net2-java-docrn下列【新】软件包将被安装:rn eclipse-cdt eclipse-cdt-jni eclipse-emf eclipse-rse libcommons-net2-javarn升级了 0 个软件包,新安装了 5 个软件包,要卸载 0 个软件包,有 0 个软件包未被升级。rn需要下载 47.2 MB/51.9 MB 的软件包。rn解压缩后会消耗掉 57.7 MB 的额外空间。rn您希望继续执行吗?[Y/n]Yrn错误 http://cn.archive.ubuntu.com/ubuntu/ precise-updates/universe eclipse-rse all 3.1.2-1build0.12.04.1rn 无法连接上 cn.archive.ubuntu.com:80 (202.118.1.64)。 - connect (111: 拒绝连接)rn错误 http://cn.archive.ubuntu.com/ubuntu/ precise/universe eclipse-cdt all 8.0.2-1rn 不能连接到 cn.archive.ubuntu.com:http:rn无法下载 http://cn.archive.ubuntu.com/ubuntu/pool/universe/e/eclipse-rse/eclipse-rse_3.1.2-1build0.12.04.1_all.deb 无法连接上 cn.archive.ubuntu.com:80 (202.118.1.64)。 - connect (111: 拒绝连接)rn无法下载 http://cn.archive.ubuntu.com/ubuntu/pool/universe/e/eclipse-cdt/eclipse-cdt_8.0.2-1_all.deb 不能连接到 cn.archive.ubuntu.com:http:rnE: 有几个软件包无法下载,您可以运行 apt-get update 或者加上 --fix-missing 的选项再试试?rnrn[color=#339966]能够ping 通 cn.archive.ubuntu.com;rn同时也 apt-get update 过了,update时好像部分链接连不上。[/color]rnrn求问这个怎么破?谢谢。 论坛

没有更多推荐了,返回首页