HNU 21

题目意思 求n的阶乘能被21除几次

链接

Problem description

As a youth of 21st century, Ming loves the number 21. One day, he met a problem. By given a positive integer he must calculate how many n! can be divided exactly by 21 at the same time? For example, 7! can only be divided by 21 exactly 1 times at the same time. If n is little, we can directly calculate the results simple. However, n is very large, Ming’s math is poor. Can you help Ming to solve this problem?


Input

Input a integer number n, 0 < n < 109, end with EOF.


Sample Input

7
9
14

Sample Output

1
1
2

我的思路,一开始我就想到能被21整除,那么21可以化成3*7;

那么题目的意思就可以化成N的阶乘能除以7几次,嗯,想法没错,但是怎么把7找出来想了大概两个月

后来灵光一闪,枚举7的次幂,多谢楼上老王

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
int main()
{
    long long a[100];
    a[0]=1;int i;
    for(i=1;i<=10;i++)
    {
        a[i]=a[i-1]*7;
    }
    long long n;
    long long sum=0;
    while(scanf("%lld",&n)!=EOF)
    {
        sum=0;
        for(i=1;i<=10;i++)
        {
            if(a[i]>n)
            break;
            else
            {

                sum+=n/a[i];
            }
        }
        printf("%lld\n",sum);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值