activemq java版本要求

<pre name="code" class="html">activemq:

redis01:/root# cp apache-activemq-5.13.2-bin.tar.gz /usr/local/

安装目录:
redis01:/usr/local/apache-activemq-5.13.2# pwd
/usr/local/apache-activemq-5.13.2

添加ACTIVEMQ_OPTS_MEMORY的配置为ACTIVEMQ_OPTS_MEMORY="-Xms256M -Xmx384M -XX:PermSize=256M -XX:MaxPermSize=384M"
/usr/local/activemq/bin/activemq start
netstat -lnp|grep 61616
完成后添加/usr/local/activemq/bin/activemq start到自启动
配置好后可以登录监控管理页面去看队列情况
 http://192.168.100.15:8161/admin/queues.jsp

默认用户密码 admin/admin

当前版本默认开启密码认证:
    <bean id="securityConstraint" class="org.eclipse.jetty.util.security.Constraint">
        <property name="name" value="BASIC" />
        <property name="roles" value="user,admin" />
        <!-- set authenticate=false to disable login -->
        <property name="authenticate" value="true" />
    </bean>
    <bean id="adminSecurityConstraint" class="org.eclipse.jetty.util.security.Constraint">
        <property name="name" value="BASIC" />
        <property name="roles" value="admin" />
         <!-- set authenticate=false to disable login -->
        <property name="authenticate" value="true" />


redis01:/usr/local/apache-activemq-5.13.2# vim  conf/jetty-realm.properties 

修改密码

需要的Java版本:
redis01:/usr/bin# rpm -qa | grep java
tzdata-java-2013g-1.el6.noarch
java-1.7.0-openjdk-1.7.0.45-2.4.3.3.el6.x86_64
java-1.6.0-openjdk-1.6.0.0-1.66.1.13.0.el6.x86_64



            
阅读更多
个人分类: ActiveMq
上一篇模块
下一篇对象(上):
想对作者说点什么? 我来说一句

linux-apache-activemq-5.15.3和 linux-jdk1.8

2018年05月22日 206.82MB 下载

activemq稳定版

2016年12月05日 46.31MB 下载

最新稳定版ActiveMQ5.15.0

2017年07月25日 55.39MB 下载

没有更多推荐了,返回首页

关闭
关闭