HDU1024 Max Sum Plus Plus ——dp

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30682    Accepted Submission(s): 10828


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^
 

Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
 

Output
Output the maximal summation described above in one line.
 

Sample Input
  
  
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 

Sample Output
  
  
6 8
Hint
Huge input, scanf and dynamic programming is recommended.
 

Author
JGShining(极光炫影)

题意:给一个数字序列,求其中的m段的和,使这个和最大。这m段互不相交。

分析:使用动态规划。dp[i][j]表示前j个数字中的i段最大和,并且它的最后一段是以a[j]结尾的。状态转移方程为:

dp[i][j] = max(dp[i][j-1]+a[j], dp[i-1][k]+a[j]),其中k的取值范围是:i-1<= k <=j-1

解释:1、dp[i][j-1]是前j-1个元素分成了i段,这个时候只需要将a[j]加在最后一段即可

2、dp[i-1][k]是前k个元素分成了i-1段,这个时候将a[j]这一个数作为第i段。

代码:

#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;
#define N 1000005
typedef long long ll;
ll dp[2][N];
ll a[N];

int main(){
	int n, m;
	while(~scanf("%d", &m)){
		scanf("%d", &n);
		for(int i = 1; i <= n; i++)
			scanf("%lld", &a[i]);
		for(int i = 0; i <= n; i++)
			dp[0][i] = dp[1][i] = 0;
		int index = 0;
		for(int i = 1; i <= m; i++){
			dp[index][i] = dp[1-index][i-1] + a[i];
			ll M = dp[1-index][i-1];
			for(int j = i+1; j <= n-m+i; j++){
				M = max(M, dp[1-index][j-1]);
				dp[index][j] = max(dp[index][j-1], M) + a[j];
			}
			index = 1 - index;
		}
		index = 1 - index;
		ll ans = dp[index][m];
		for(int i = m+1; i <= n; i++)
			ans = max(ans, dp[index][i]);
		printf("%lld\n", ans);
	}
	return 0;
} 
注意代码中的优化,如果k值每次都从i-1到j-1遍历一遍的话,会超时。

因此用一个M表示dp[i-1][i-1]到dp[i-1][j-1]的最大值,j每次+1时都更新M为从i-1到j-1的最大值。


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值