使用swfdec软件在ubuntu下播放flash

使用swfdec软件在ubuntu下播放flash

之前在Fedora上安装时,提示需要ALSA1.0版本以上支持,下载ALSA的三个源码文件后,编译出错,于是回到ubuntu上编译,在安装
若干库文件后,编译成功。

第一步:网上下载swfdec-0.8.4安装源文件; 

第二步:执行./configure,弹出如下错误:
checking for PANGO... no
configure: error: pangocairo >= 1.16 is required to build swfdec
使用apt-cache search pango查询,找到libpango1.0-dev - Development files for the Pango,
安装:
apt-get install libpango1.0-dev
再./configure
弹出如下错误:
checking for GTK... configure: error: Package requirements (gtk+-2.0 >= 2.8.0 libsoup-2.4) were not met:

No package 'gtk+-2.0' found
No package 'libsoup-2.4' found
使用apt-cache search gtk2.0查询,
libgtk2.0-dev - Development files for the GTK+ librar
安装:
apt-cache search libsoup
找到
libsoup2.4-dev - an HTTP library implementation in C -- Development files
安装;
继续./configure,提示错误:
configure: error: liboil-0.3 >= 0.3.1 is required to build swfdec
查找
liboil0.3-dev - Library of Optimized Inner Loops (development headers)
安装;
继续:
configure: error: Couldn't find GStreamer 0.10.11 and gstreamer-pbutils 0.10.15.
查找
libgstreamermm-0.10-dev - C++ wrapper library for the multimedia library GStreamer (development files)
安装;
再./configure,配置成功,再make,在player目录下生成swfplay文件,使用如下指令执行:
./swfplay *.swf

将swfdec configure bak
remove -Waddress


./configure --cc=arm-none-linux-gnueabi-gcc
./configure CC=arm-none-linux-gnueabi-gcc
阅读更多
上一篇NGUITools.AddChild
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭