1101. Quick Sort (25)

13 篇文章 7 订阅
时间限制:200 ms        内存限制:65536 kB       代码长度限制:16000 B       判题程序:Standard      作者:CAO, Peng

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N = 5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

    Hence in total there are 3 pivot candidates.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (<= 105). Then the next line contains N distinct positive integers no larger than 109. The numbers in a line are separated by spaces.

    Output Specification:

    For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

    Sample Input:

    5
    1 3 2 4 5
    

    Sample Output:

    3
    1 4 5
    

    容易认为原数组和排序后的数组同一位置相同的数的即为pivot candidate,实际上,可以找到反例: 1、3、1、1,显然据此方法第2个1会被错误当作pivot candiate。正确姿势是,根据pivot candidate的定义,即大于数组前面的数、小于数组后面的数,我们记 minS[i]为s[i~n]中最小值,maxS[i]为s[1~i]中最大值(s为给定数组),然后扫描数组s时和minS及maxS进行相应比较即可。

  • #include <cstdio>
    #include <iostream>
    
    using namespace std;
    
    const int N = 1e5+5;
    
    int main(){
    //  freopen("Data.txt","r",stdin); 
    //  bool flag[N]={true}; //只将flag[0]初始化为true(1) 
        int s[N],minS[N],maxS[N],res[N];
        int i,n,count;
        scanf("%d",&n);
        for(i=1;i<=n;i++) scanf("%d",&s[i]);
        //从后往前扫描一边得到minS[i],从前往后扫描一边得到maxS[i];
        minS[n] = s[n];
        maxS[1] = s[1];
        for(i=n-1;i>=1;i--){
            if(s[i]<=minS[i+1]) minS[i] = s[i];
            else minS[i] = minS[i+1];
        }
        for(i=2;i<=n;i++){
            if(s[i]>=maxS[i-1]) maxS[i] = s[i]; 
            else maxS[i] = maxS[i-1];
        }
        //find
        maxS[0] = 0;
        minS[n+1] = 1e9+5;
        count = 0;
        for(i=1;i<=n;i++){
            if(s[i]>=maxS[i-1] && s[i]<=minS[i+1])
                res[count++] = s[i];
        }
        //show
        printf("%d\n",count);
        if(!count) printf("\n"); //样例设置的原因,要单独输出'换行' 
        for(i=0;i<count;i++){
            printf("%d",res[i]);
            if(i<count-1) printf(" ");
            else printf("\n");
        }
        return 0;
    }
    

    14:26 2018/1/31

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值