ubuntu16.04安装cajviewer

1.在官网下载 CAJViewer for linux
   http://cajviewer.cnki.net/download.html

2.下载得到的文件是 CAJViewer-x86_64-libc-2.24.AppImage,将其移动到一个存放软件的目录中

mv CAJViewer-x86_64-libc-2.24.AppImage /home/zqzy/software/

3.添加执行权限

cd /home/zqzy/software
sudo chmod a+x CAJViewer-x86_64-libc-2.24.AppImage

4.运行方式,在终端直接输入以下指令即可运行

./CAJViewer-x86_64-libc-2.24.AppImage

5.如果报错

./CAJViewer-x86_64-libc-2.24.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: 
version `GLIBCXX_3.4.22' not found (required by ./CAJViewer-x86_64-libc-2.24.AppImage)

6.解决方法

sudo add-apt-repository ppa:ubuntu-toolchain-r/test 

上面执行时,可能会提示连接超时,失败,如下

忽略即可,继续执行下面的命令

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install libstdc++6

执行完后,重新打开,即可

cd /home/zqzy/software
./CAJViewer-x86_64-libc-2.24.AppImage

 

参考:https://blog.csdn.net/weixin_43976833/article/details/106087392

相关推荐
©️2020 CSDN 皮肤主题: 技术黑板 设计师:CSDN官方博客 返回首页