HDU 3199 Hamming Problem

Hamming Problem
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

For each three prime numbers p1, p2 and p3, let's define Hamming sequence Hi(p1, p2, p3), i=1, ... as containing in increasing order all the natural numbers whose only prime divisors are p1, p2 or p3. 

For example, H(2, 3, 5) = 2, 3, 4, 5, 6, 8, 9, 10, 12, 15, 16, 18, 20, 24, 25, 27, ... 

So H5(2, 3, 5)=6. 
 

Input

In the single line of input file there are space-separated integers p1 p2 p3 i.
 

Output

The output file must contain the single integer - Hi(p1, p2, p3). All numbers in input and output are less than 10^18. 
 

Sample Input

     
     
7 13 19 100
 

Sample Output

     
     
26590291

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
using namespace std;
typedef long long ll;
ll num[10000];

int main(){
	ll p1, p2, p3, n;
	while(~scanf("%I64d%I64d%I64d%i64d", &p1, &p2, &p3, &n)){
		memset(num, 0, sizeof(num));
		num[0] = 1;		
		ll t1, t2, t3;
		ll r1, r2, r3;		
		t1 = t2 = t3 = 0;
		for(int i = 1; i <= n; ++i){
			r1 = num[t1] * p1;
			r2 = num[t2] * p2;
			r3 = num[t3] * p3;
			ll minn = min(r1, min(r2, r3));
			if(minn == r1) ++t1;
			if(minn == r2) ++t2;
			if(minn == r3) ++t3;
			num[i] = minn;
		}		
		cout << num[n] << endl;
	}
	
	return 0;
}

看着给出的数据范围很大,其实 i 的范围在10000 就能过。

刚开始没有思路,看了别人的代码才恍然大悟。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值