Could not find jar tool executable J2ME混淆器出錯

Could not find jar tool executable

 一直存在这个问题,看看不影响效果,现在终于有觉得的办法了。

eclipse 中,普通打包方式以及用PROGUARD生成混淆包Obfuscated Package的时候出错:

Could not find jar tool executable. The jar tool requires a full JDK installation Specify a full JDK installation int the Java preferences.

Reason Could not find jar tool executeable 需要一个完整的JDK安装,但是我已经装了完正的JDK。

解决方案: 在“窗口--首选项--java--已经安装的JRE”中,对应英文为“windows-preferences-java-installed jres”把已经安装的JRE的目录修改为jdk的安装目录。

原因: 在混淆的过程中,混淆工具产生的JAR文件需要被再次预校验。

此时,预处理工具会从环境变量中寻找并调用jar工具的可执行文件。

EclipseME一般会在JRE安装目录下面去寻找。

如果发生这个问题了,肯定是因为EclipseME在已经安装的JRE(java的子类)中找到了至少一个JDK。这种情况下,在Windows下,Eclipse会默认识别JRE而不是JDK。

©️2020 CSDN 皮肤主题: 程序猿惹谁了 设计师:上身试试 返回首页