华为路由器交换机配置命令大整合,非常全,附pdf下载!

路由 同时被 3 个专栏收录
8 篇文章 0 订阅
18 篇文章 0 订阅
6 篇文章 0 订阅

 

  • 一、计算机命令:【基于linux系统下的相关命令】

  • 二、交换机命令

  • 三、路由器命令

    • 3.1静态路由

    • 3.2动态路由

  • 四、扩展访问控制列表配置命令:

    • 4.1标准格式:

    • 4.2配置TCP/UDP协议的扩展访问列表:

    • 4.3配置ICMP协议的扩展访问列表:

    • 4.4扩展访问控制列表操作符的含义:

    • 4.5扩展访问控制列表举例:

  • 五、地址转换配置举例

    • 5.1内部服务器地址转换配置命令(静态nat):

  • 六、PPP:

  • 七、帧中继frame-relay :

    • 7.1帧中继监测

  • 八、启动ftp服务:

  • 九、配置 DHCP服务

  • 十、配置地址池和地址列表

    • 10.1 QuidWay系列交换机

    • 10.2 3500/3026E/3026F/3050 交换机

    • 10.3 S3600系列交换机

    • 10.4 S6500/S7500 系列交换机

  • 十一、华为交换机配置命令解释

 

一、计算机命令:【基于linux系统下的相关命令】

PCAlogin:root;       使用root用户
password:linux;      口令是linux
shutdown -h now;、init0;   关机
logout;         用户注销
login;         用户登录
ifconfig;        显示IP地址
ifconfig eth0 netmask;    设置IP地址
ifconfig eht0 netmask down;   禁用IP地址
route add 0.0.0.0 gw;     设置网关
route de l0.0.0.0 gw;     删除网关
route add default gw;     设置网关
route del default gw;     删除网关
route;         显示网关
ping;          发ECHO包
telnet;         远程登录

二、交换机命令

[Quidway]dis cur;          显示当前配置
[Quidway]display current-configuration;  显示当前配置
[Quidway]display interfaces;      显示接口信息
[Quidway]display vlanall;       显示路由信息
[Quidway]display version;       显示版本信息
[Quidway]super password;        修改特权用户密码
[Quidway]sysname;          交换机命名
[Quidway]interface ethernet0/1;     进入接口视图
[Quidway]interface vlanx;       进入接口视图
[Quidway]dis log          查看交换机日志
[Quidway-Vlan-interfacex]ip address 10.65.1.1 255.255.0.0;                  配置VLAN的IP地址

[Quidway]ip route-static 0.0.0.0 0.0.0.0 10.65.1.2;
静态路由=网关

[Quidway]rip;           三层交换支持
[Quidway]local-user ftp         【没有,找不到】
[Quidway]user-interface vty 0 4;     进入虚拟终端
[S3026-ui-vty0-4]authentication-mode password; 设置口令模式
[S3026-ui-vty0-4]set authentication-mode password simple222;                   设置口令
[S3026-ui-vty0-4]user privilege level3;    用户级别
[Quidway]interface ethernet0/1;       进入端口模式
[Quidway]int e0/1;            进入端口模式
[Quidway-Ethernet0/1]duplex{half|full|auto};配置端口工作状态
[Quidway-Ethernet0/1]speed{10|100|auto};  配置端口工作速率
[Quidway-Ethernet0/1]flow-control;     配置端口流控

[Quidway-Ethernet0/1]mdi{across|auto|normal};
配置端口平接扭接

[Quidway-Ethernet0/1]port link-type {trunk|access|hybrid};
设置端口工作模式

[Quidway-Ethernet0/1]port access vlan3;  当前端口加入到VLAN

[Quidway-Ethernet0/2]port trunk permit vlan{ID|All};
设trunk允许的VLAN

[Quidway-Ethernet0/3]port trunk pvid vlan3; 设置trunk端口的PVID
[Quidway-Ethernet0/1]undo shutdown;    激活端口
[Quidway-Ethernet0/1]shutdown;      关闭端口
[Quidway-Ethernet0/1]quit;       返回
[Quidway]vlan3;           创建VLAN

[Quidway-vlan3]port ethernet0/1;      在VLAN中增加端口
[Quidway-vlan3]port ethernet0/1 to ethernet0/4;在VLAN中增加端口
[Quidway-vlan3]port e0/1;        简写方式
[Quidway-vlan3]port e0/1 to e0/4;      简写方式

[Quidway]monitor-port;         指定镜像端口
[Quidway]portmirror;         指定被镜像端口
[Quidway]portmirrorint_listobserving-portint_typeint_num;
指定镜像和被镜像
[Quidway]description string;        指定VLAN描述字符
[Quidway]description;          删除VLAN描述字符
[Quidway]displayvlan[vlan_id];      查看VLAN设置
[Quidway]stp{enable|disable};      设置生成树,默认关闭
[Quidway]stp priority 4096;       设置交换机的优先级
[Quidway]stp root{primary|secondary};  设置为根或根的备份
[Quidway-Ethernet0/1]stp cost200;    设置交换机端口的花费
[Quidway]link-aggregatione0/1toe0/4ingress|both; 端口的聚合
[Quidway]undolink-aggregatione0/1|all;   始端口为通道号
[SwitchA-vlanx]isolate-user-vlanenable;  设置主vlan
[SwitchA]isolate-user-vlansecondary;  设置主vlan包括的子vlan
[Quidway-Ethernet0/2]port hybrid pvid vlan;  设置vlan的pvid
[Quidway-Ethernet0/2]port hybrid pvid;   删除vlan的pvid

[Quidway-Ethernet0/2]porthybridvlanvlan_id_listuntagged;
设置无标识的vlan,如果包的vlanid与PVId一致,则去掉vlan信息.默认PVID=1。所以设置PVID为所属vlanid,设置可以互通的vlan为untagged.

三、路由器命令

[Quidway]display version;       显示版本信息
[Quidway]display current-configuration;  显示当前配置
[Quidway]display interfaces;      显示接口信息
[Quidway]display ip route;       显示路由信息
[Quidway]sysname aabbcc;       更改主机名
[Quidway]super passwrod 123456;     设置口令
[Quidway]interface serial0;      进入接口
[Quidway-serial0]ip address;      配置端口IP地址
[Quidway-serial0]undo shutdown;     激活端口
[Quidway]link-protocol hdlc;      绑定hdlc协议
[Quidway]user-interface vty 0 4
[Quidway-ui-vty0-4]authentication-mode password
[Quidway-ui-vty0-4]setauthentication-mode password simple 222
[Quidway-ui-vty0-4]user privilege level3
[Quidway-ui-vty0-4]quit         【没有】
[Quidway]debugging hdlc all serial0;    显示所有信息
[Quidway]debugging hdlc event serial0;   调试事件信息
[Quidway]debugging hdlc packet serial0;  显示包的信息

3.1静态路由

[Quidway]iproute-static{interfacenumber|nexthop}
[value][reject|blackhole] 例如:
[Quidway]iproute-static 129.1.0.0 16 10.0.0.2
[Quidway]iproute-static 129.1.0.0 255.255.0.0 10.0.0.2
[Quidway]iproute-static 129.1.0.0 16 Serial2
[Quidway]iproute-static 0.0.0.0 0.0.0.0 10.0.0.2

3.2动态路由

[Quidway]rip;          设置动态路由
[Quidway]ripwork;         设置工作允许
[Quidway]rip input;        设置入口允许
[Quidway]rip output;        设置出口允许
[Quidway-rip]network 1.0.0.0;    设置交换路由网络
[Quidway-rip]network all;      设置与所有网络交换
[Quidway-rip]peer ip-address;    【没有】
[Quidway-rip]summary;       路由聚合
[Quidway]rip version1;       设置工作在版本1
[Quidway]rip version2 multicast;    设版本2,多播方式
[Quidway-Ethernet0]rip split-horizon; 水平分隔
[Quidway]routerid A.B.C.D;      配置路由器的ID
[Quidway]ospf enable;       启动OSPF协议
[Quidway-ospf]import-route direct;   引入直联路由
[Quidway-Serial0]ospf enable area;   配置OSPF区域

获取更多题库内容或hcia/hcip/hcie相关学习资料可 + Q 裙 :696283186

四、扩展访问控制列表配置命令:

4.1标准格式:

acl[match-orderconfig|auto] 默认前者顺序匹配。

rule[normal|special]{permit|deny}[sourcesource-addrsource-wildcard|any]

例:

[Quidway]acl 10
[Quidway-acl-10]rule normal permit source 10.0.0.0 0.0.0.255
[Quidway-acl-10]rule normal deny source any

4.2配置TCP/UDP协议的扩展访问列表:

rule{normal|special}{permit|deny}{tcp|udp}source{|any}destination|any}
[operate]

4.3配置ICMP协议的扩展访问列表:

rule{normal|special}{permit|deny}icmpsource{|any]destination{|any]
[icmp-code][logging]

4.4扩展访问控制列表操作符的含义:

  • equalportnumber; 等于

  • greater-thanportnumber; 大于

  • less-thanportnumber; 小于

  • not-equalportnumber; 不等

  • range portnumber1 portnumber2;区间

4.5扩展访问控制列表举例:

[Quidway]acl 101
[Quidway-acl-101]rule deny souce any destination any
[Quidway-acl-101]rule permit icmp source any destinationany icmp-type echo
[Quidway-acl-101]rule permit icmp source any destination any icmp-type echo-reply
[Quidway]acl 102
[Quidway-acl-102]rule permit ip source 10.0.0.1 0.0.0.0 destination 202.0.0.1 0.0.0.0
[Quidway-acl-102]rule deny ip source any destination any
[Quidway]acl 103
[Quidway-acl-103]rule permit tcp source any destination 10.0.0.1 0.0.0.0 destination-port equal ftp

[Quidway-acl-103]rule permit tcp source any destination 10.0.0.2 0.0.0.0 destination-port equal www
[Quidway]firewall enable
[Quidway]firewall default permit|deny
[Quidway]inte0
[Quidway-Ethernet0]firewall packet-filter 101 inbound|outbound

五、地址转换配置举例

[Quidway]firewall enable
[Quidway]firewall default permit
[Quidway]acl101;内部指定主机可以进入e0
[Quidway-acl-101]rule deny ip source any destination any
[Quidway-acl-101]rule permit ip source 129.38.1.10 destination any
[Quidway-acl-101]rule permit ip source 129.38.1.20 destination any
[Quidway-acl-101]rule permit ip source 129.38.1.30 destination any
[Quidway-acl-101]rule permit ip source 129.38.1.40 destination any
[Quidway-acl-101]quit
[Quidway]int e0
[Quidway-Ethernet0]firewall packet-filter 101 inbound
[Quidway]acl102;外部特定主机和大于1024端口的数据包允许进入S0
[Quidway-acl-102]rule deny ip source any destination any
[Quidway-acl-102]rule permit tcp source 202.39.2.30 destination 202.38.160.10
[Quidway-acl-102]rule permit tcp source any destination 202.38.160.10 destination-portgreat-than 1024
[Quidway-acl-102]quit
[Quidway]int s0
[Quidway-Serial0]firewall packet-filter 102 inbou 设202.38.160.1是路由器出口IP。
[Quidway-Serial0]nat outbound 101 +interface;是Easyip,将acl101允许的IP从本接口出时变换源地址。

5.1内部服务器地址转换配置命令(静态nat):

nat server global [port] inside port [protocol] global_port不写时使用inside_port

[Quidway-Serial0]nat server global 202.38.160.1 inside 129.38.1.1 ftp tcp
[Quidway-Serial0]nat server global 202.38.160.1 inside 129.38.1.2 telnet tcp
[Quidway-Serial0]nat server global 202.38.160.1 inside 129.38.1.3 www tcp

设有公网IP:202.38.160.101~202.38.160.103可以使用。对外访问

[Quidway]nat address-group 202.38.160.101 202.38.160.103 pool1;

建立地址池

[Quidway]acl1
[Quidway-acl-1]rule permit source 10.110.10.0 0.0.0.255;

指定允许的内部网络

[Quidway-acl-1]rule deny source any
[Quidway-acl-1]int serial0
[Quidway-Serial0]nat out bound1 address-group pool1;

在s0口从地址池取出IP对外访问

[Quidway-Serial0]nat server global 202.38.160.101 inside 10.110.10.1 ftp tcp
[Quidway-Serial0]nat server global 202.38.160.102 inside 10.110.10.2 www tcp
[Quidway-Serial0]nat server global 202.38.160.102 8080 inside 10.110.10.3 www tcp
[Quidway-Serial0]nat server global 202.38.160.103 inside 10.110.10.4 smtp udp

获取更多题库内容或hcia/hcip/hcie相关学习资料可 + Q 裙 :696283186

六、PPP:

设置:[Quidway-s0]link-protocol ppp默认的协议

验证:主验方:pap|chap

[Quidway]local-userq2 password {simple|cipher} hello;路由器1
[Quidway]interface serial0
[Quidway-serial0]ppp authentication-mode {pap|chap}
[Quidway-serial0]ppp chap userq1;pap时,没有此句

pap被验方:

[Quidway]interface serial0;路由器2
[Quidway-serial0]ppp pap local-userq2 password {simple|cipher} hello

chap被验方:

[Quidway]interface serial0;路由器2
[Quidway-serial0]ppp chap userq2;自己路由器名
[Quidway-serial0]local-userq1 password {simple|cipher} hello;对方路由器名

七、帧中继frame-relay :

[q1]fr switching
[q1]int s1
[q1-Serial1]ip address 192.168.34.51 255.255.255.0
[q1-Serial1]link-protocol fr;封装帧中继协议
[q1-Serial1]fr interface-type dce
[q1-Serial1]frdlci100
[q1-Serial1]frinarp
[q1-Serial1]frmap ip 192.168.34.52dlci100
[q2]int s1
[q2-Serial1]ip address 192.168.34.52 255.255.255.0
[q2-Serial1]link-protocol fr
[q2-Serial1]fr interface-type dte
[q2-Serial1]fr dlci100
[q2-Serial1]fr in arp
[q2-Serial1]frmap ip 192.168.34.51 dlci 100

7.1帧中继监测

[q1]display frlmi-info[]interfacetypenumber]
[q1]display frmap
[q1]display frpvc-info[serialinterface-number][dlcidlci-number]
[q1]display frdlci-switch
[q1]display frinterface
[q1]reset frinarp-info
[q1]debugging frall[interfacetypenumber]
[q1]debugging frarp[interfacetypenumber]
[q1]debugging frevent[interfacetypenumber]
[q1]debugging frlmi[interfacetypenumber]

八、启动ftp服务:

[Quidway]local-user ftp password {simple|cipher} aaa service-type ftp
[Quidway]ftp server enable

九、配置 DHCP服务

# 使能 DHCP服务。
<HuaWei> system-view 
[HuaWei] dhcp enable
# 配置不参与自动分配的 IP 地址(DNS服务器、WINS服务器和出口网关地址) 。

[HuaWei] dhcp server forbidden-ip 10.1.1.2 
[HuaWei] dhcp server forbidden-ip 10.1.1.4 
[HuaWei] dhcp server forbidden-ip 10.1.1.126 
[HuaWei] dhcp server forbidden-ip 10.1.1.254
# 配置 DHCP地址池 1 的属性(地址池范围、出口网关、地址租用期限、 dns 服务器)。

[HuaWei] dhcp server ip-pool 1
[HuaWei-dhcp-pool-1] network 10.1.1.0 mask 255.255.255.128
[HuaWei-dhcp-pool-1] gateway-list 10.1.1.126
[HuaWei-dhcp-pool-1] domain-name vlan20
[HuaWei-dhcp-pool-1] dns-list 202.106.116.1 202.106.0.20 
[HuaWei-dhcp-pool-1] expired day 8
[HuaWei-dhcp-pool-1] quit

十、配置地址池和地址列表

[Router] nat address-group 202.38.160.101 202.38.160.103 pool1
[Router] acl 2000
[Router-acl-2000]rule permit source 10.110.10.0 0.0.0.255
#  允许 10.110.10.0/24 的网段进行地址转换
[Router-Serial0] nat outbound 2000 address-group pool
#  设置内部 FTP 服务器
[Router-Serial0] nat server global 202.38.160.101 inside 10.110.10.1 ftp tcp
#  设置内部 WWW服务器 1
[Router-Serial0] nat server global 202.38.160.102 inside 10.110.10.2 www tcp
#  设置内部 WWW服务器 2
[Router-Serial0] nat server global 202.38.160.102 8080 inside 10.110.10.3 www tcp
#  设置内部 SMTP 服务器
[Router-Serial0] nat server global 202.38.160.103 inside 10.110.10.4 smtp udp

内部局域网通过地址转换后拨号访问 Internet

10.1 QuidWay系列交换机

方法 1:

  1. 配置镜像端口

system-view
[HuaWei] monitor-port Ethernet 0/24
  1. 配置被镜像端口

[HuaWei] port mirror Ethernet 0/1 to Ethernet 0/8

方法 2:

[HuaWei] port mirror Ethernet 0/1 to Ethernet 0/8 observing-port Ethernet
0/24 

基于流镜像的数据流程

基于流镜像的交换机针对某些流进行镜像, 每个连接都有两个方向的数据流, 对于交换机来说这两个数据流是要分开镜像的。

10.2 3500/3026E/3026F/3050 交换机

基于三层流的镜像

  1. 定义一条扩展访问控制列表 ACL

[SwitchA]acl num 100
  1. 定义一条规则报文源地址为 1.1.1.1/32 去往所有目的地址

[SwitchA-acl-adv-101]rule 0 permit ip source 1.1.1.1 0 destination any
  1. 定义一条规则报文源地址为所有源地址目的地址为 1.1.1.1/32

[SwitchA-acl-adv-101]rule 1 permit ip source any destination 1.1.1.1 0
  1. 将符合上述 ACL规则的报文镜像到 E0/8 端口

[SwitchA]mirrored-to ip-group 100 interface e0/8

基于二层流的镜像

  1. 定 义 一 个 ACL

[SwitchA]acl num 200
  1. 定义一个规则从 E0/1 发送至其它所有端口的数据包

[SwitchA]rule 0 permit ingress interface Ethernet0/1 egress interface Ethernet0/2
  1. 定义一个规则从其它所有端口到 E0/1 端口的数据包

[SwitchA]rule 1 permit ingress interface Ethernet0/2 egress interface Ethernet0/1
  1. 将符合上述 ACL的数据包镜像到 E0/8

[SwitchA]mirrored-to link-group 200 interface e0/8

10.3 S3600系列交换机

10.3.1在端口视图下配置

system-view
[HuaWei] mirroring-group 1 local
[HuaWei] interface gigabitEthernet 1/1/4 
[HuaWei-GigabitEthernet1/1/4] monitor-port 
[HuaWei-GigabitEthernet1/1/4] quit
[HuaWei] interface gigabitEthernet 1/1/1
[HuaWei-GigabitEthernet1/1/1] mirroring-port both

10.3.2在端口视图下配置

system-view
[HuaWei] mirroring-group 1 local
[HuaWei] interface GigabitEthernet 1/1/4
[HuaWei-GigabitEthernet1/1/4] mirroring-group 1 monitor-port 
[HuaWei-GigabitEthernet1/1/4] quit
[HuaWei] interface GigabitEthernet 1/1/1
[HuaWei-GigabitEthernet1/1/1] mirroring-group 1 mirroring-port both

10.3.3在系统视图下配置:

system-view
[HuaWei] mirroring-group 1 local
[HuaWei] mirroring-group 1 monitor-port GigabitEthernet 1/1/4  [HuaWei] mirroring-group 1 mirroring-port GigabitEthernet 1/1/1 both

10.4 S6500/S7500 系列交换机

10.4.1以太网端口视图下配置端口镜像

  1. 创建端口镜像组

<SWITCH> system-view [SWITCH] mirroring-group 1 local
  1. 进入镜像目的端口的以太网端口视图

[SWITCH] interface GigabitEthernet 1/0/2
  1. 定义当前端口为镜像目的端口 [SWITCH-GigabitEthernet1/0/2] mirroring-group 1 monitor-port

  2. 进入镜像源端口的以太网端口视图

  [SWITCH] interface GigabitEthernet 1/0/1
  1. 配置镜像源端口,同时指定被镜像报文的方向

[SWITCH-GigabitEthernet1/0/1] mirroring-group 1 mirroring-port both

10.4.2系统视图下配置端口镜像

  1. 创建端口镜像组。

<SWITCH> system-view [SWITCH] mirroring-group 1 local
  1. 配置镜像目的端口。

[SWITCH] mirroring-group 1 monitor-port GigabitEthernet 1/0/2
  1. 配置镜像源端口,同时指定被镜像报文的方向。

[SWITCH] mirroring-group 1 mirroring-port GigabitEthernet 1/0/1 both

获取更多题库内容或hcia/hcip/hcie相关学习资料可 + Q 裙 :696283186

十一、华为交换机配置命令解释

<Quidway>用户视图,只能看配置
<Quidway>reset save (清除配置文件)
<Quidway>reboot (重启华为交换机)
<Quidway>system view (进入配置模式)
<Quidway>sys (省略式打法)

[]表示配置模式

修改交换机:

[Quidway]sysname sw1
[sw1]

配置VLAN:

[Quidway]vlan 2
[Quidway-vlan2]port ether 0/10 to e 0/12
[Quidway-vlan2]quit

等同于

[Quidway]int e0/13
[Quidway-Ethernet0/13]port access vlan 2
[Quidway-Ethernet0/13]quit

配置trunk端口:

[Quidway]int e0/1
[Quidway-Ethernet0/1]port link-type trunk
[Quidway-Ethernet0/1]int e0/2
[Quidway-Ethernet0/2]port link-type trunk
[Quidway-Ethernet0/2]quit

两边的端口都要配trunk,通过trunk 不打标签!默认trunk 只允许vlan 1 通过

[Quidway]int e0/1
[Quidway-Ethernet0/1]port trunk permit vlan all
[Quidway-Ethernet0/1]int e0/2
[Quidway-Ethernet0/2]port trunk permit vlan all

两边端口都要配置充许trunk 所有VLAN,如果是指定通过 vlan号,将vlan all 改成对应的vlan编号即可。

取消任何命令,是在命令前面加一个 undo 即可!

如何防止交换机环路:

华为的交换机生成树功能默认是关掉的交换机形成环路,所联接的端口会不停的闪烁!

方法一:启用交换机生成树

[Quidway]stp enable(开)
[Quidway]stp disable(关)

要在两台交换机上配置

方法二:通过链路聚合的方式来解决问题

链路聚合可以提高带宽和负载均衡,配置链路聚合时,两端的端口模式需要配置成一样(双工,半又工),速率也要指定,不能自己自协商状态!

[Quidway]link-aggregation e0/1 to e0/2 both

如:

[Quidway]int e0/1
[Quidway-Ethernet0/1]duplex full
[Quidway-Ethernet0/1]speed 100
[Quidway-Ethernet0/1]int e0/2
[Quidway-Ethernet0/2]duplex full
[Quidway-Ethernet0/2]speed 100

【华为路由器交换机配置命令】的下载链接和密码:

链接:https://wljslmz.lanzous.com/i9O1Djmfgah
密码:2333

 需要更多华为认证方面学习资料以及视频资料可以加入文章开头的认证群,喜欢收藏,感谢!

  • 9
    点赞
  • 0
    评论
  • 41
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

©️2021 CSDN 皮肤主题: 游动-白 设计师:白松林 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值