还是畅通工程(水题) kruskal算法

http://acm.hdu.edu.cn/showproblem.php?pid=1233


Problem Description

某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。
 
Input

测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。
 
Output
对每个测试用例,在1行里输出最小的公路总长度。
 
Sample Input

3  
1 2 1  
1 3 2  
2 3 4  
4  
1 2 1  
1 3 4  
1 4 1  
2 3 3  
2 4 2  
3 4 5
0


 
Sample Output

3

Source
浙大计算机研究生复试上机考试-2006年

&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&

分析:其实这是一道水题,最小生成树的半道题。用克鲁斯卡尔解决。

Accepted1233265MS312K945 BG++瑾予

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
 int u,v,cost;
}e[5000];
int cmp(const node&a,const node&b)//排序
{
 return a.cost<b.cost;
}
int set[5000];
int find(int x)//路径压缩
{
 if(x!=set[x])
  set[x]=find(set[x]);
 return set[x];
}

void merge(int x,int y)
{
 int fx,fy;
 fx=find(x);
 fy=find(y);
 if(fx==fy)
  return;
 if(fx<fy)
    set[fy]=fx;
 else
    set[fx]=fy;
}
int main()
{
 int n,i,h;
 while(scanf("%d",&h),h)
 {
  for(i=0;i<h;i++)
   set[i]=i;
  n=h*(h-1)/2;
  for(i=0;i<n;i++)
  {
   scanf("%d%d%d",&e[i].u,&e[i].v,&e[i].cost);
  }
  sort(e,e+n,cmp);
  /*for(i=0;i<n;i++)
   printf("%d %d %d\n",e[i].u,e[i].v,e[i].cost);*/
  int fx,fy,sum=0;
  for(i=0;i<n;i++)
  {
   fx=find(e[i].u);
   fy=find(e[i].v);
   if(fx!=fy)//作用:判重边。
   {
    merge(e[i].u,e[i].v);
    sum+=e[i].cost;
   }
  }
  printf("%d\n",sum);
 }
 return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值