Pick-up Sticks

点击打开链接

Stan has n sticks of various length. He throws them one at a time on the floor in a random way. After finishing throwing, Stan tries to find the top sticks, that is these sticks such that there is no stick on top of them. Stan has noticed that the last thrown stick is always on top but he wants to know all the sticks that are on top. Stan sticks are very, very thin such that their thickness can be neglected.

Input

Input consists of a number of cases. The data for each case start with 1 ≤ n ≤ 100000, the number of sticks for this case. The following n lines contain four numbers each, these numbers are the planar coordinates of the endpoints of one stick. The sticks are listed in the order in which Stan has thrown them. You may assume that there are no more than 1000 top sticks. The input is ended by the case with n=0. This case should not be processed.

Output

For each input case, print one line of output listing the top sticks in the format given in the sample. The top sticks should be listed in order in which they were thrown.

The picture to the right below illustrates the first case from input.

Sample Input

5
1 1 4 2
2 3 3 1
1 -2.0 8 4
1 4 8 2
3 3 6 -2.0
3
0 0 1 1
1 0 2 1
2 0 3 1
0

Sample Output

Top sticks: 2, 4, 5.
Top sticks: 1, 2, 3.


YYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYY
从前向后判断第i是否和第j根线段相交,分为点在线上和线在线上,如果只是端点与端点重合而线段不重合,则继续,否则break;此外,线段相交;也要break;


#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
double MAX(double a,double b)
{
	return a>b?a:b;
}
double MIN(double a,double b)
{
	return a<b?a:b;
}
struct point
{
	double x,y;
};
struct line
{
	point a,b;
}p[100008];
double cross(point a,point b,point c)
{
	return (c.x-a.x)*(b.y-a.y)-(c.y-a.y)*(b.x-a.x);
}
int onsegment(point a,point b,point c)
{
	double d1=MIN(a.x,b.x);
	double d2=MAX(a.x,b.x);
	double d3=MIN(a.y,b.y);
	double d4=MAX(a.y,b.y);
	if(d1<=c.x&&c.x<=d2&&d3<=c.y&&c.y<=d4)
	return 1;
	return 0;
}
int segment(point a,point b,point c,point d)
{
	double d1=cross(c,d,a);
	double d2=cross(c,d,b);
	double d3=cross(a,b,c);
	double d4=cross(a,b,d);
	if(d1*d2<0&&d3*d4<0)
	return 1;
	else if(d1==0&&onsegment(c,d,a))
	return 1;
	else if(d2==0&&onsegment(c,d,b))
	return 1;
	else if(d3==0&&onsegment(a,b,c))
	return 1;
	else if(d4==0&&onsegment(a,b,d))
	return 1;
	return 0;
}
int g[100008];
int main()
{
	int i,j,k,m,n;
	while(scanf("%d",&m),m)
	{
		for(i=0;i<m;i++)
		scanf("%lf%lf%lf%lf",&p[i].a.x,&p[i].a.y,&p[i].b.x,&p[i].b.y);
		n=0;
		for(i=0;i<m;i++)
		{
			for(j=i+1;j<m;j++)
			{
				if(segment(p[i].a,p[i].b,p[j].a,p[j].b))
				{
					if((p[i].a.x!=p[j].a.x||p[i].a.y!=p[j].a.y)&&(p[i].b.x!=p[j].a.x||p[i].b.y!=p[j].a.y)&&(p[i].a.x!=p[j].b.x||p[i].a.y!=p[j].b.y)&&(p[i].b.x!=p[j].b.x||p[i].b.y!=p[j].b.y))
					{
						break;
					}
					else
					{
						if((onsegment(p[i].a,p[i].b,p[j].a)&&onsegment(p[i].a,p[i].b,p[j].b))||(onsegment(p[j].a,p[j].b,p[i].a)&&onsegment(p[j].a,p[j].b,p[i].b)))
						break;
						else
						continue;
					}
				}
			}
			if(j==m)
			{
				g[n++]=i+1;
			}
		}
		printf("Top sticks:");
		for(i=0;i<n-1;i++)
		{
			printf(" %d,",g[i]);
		}
		printf(" %d.\n",g[n-1]);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值