A - Ultra-QuickSort

这篇博客深入探讨了快速排序算法,一种高效的排序算法。通过实例展示了如何使用该算法,包括9, 1, 0, 5, 4的排序过程,并讨论了其平均和最坏情况的时间复杂度。" 103401535,5667424,Linux下排查JAVA程序导致的CPU和内存过高问题,"['Linux CPU最高排查', 'Linux 内存过高排查', 'JAVA 应用监控', '性能优化', '系统诊断']
摘要由CSDN通过智能技术生成
In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence. Input
The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.
Output
For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.
Sample Input
5
9
1
0
5
4
3
1
2
3
0
Sample Output

60

树状数组的应用,关键在于如何转换,然后套模板。
还有离散化的应用,忽略初始值,直接考虑顺序即可。
#include<cstdio>
#include<algorithm>
#include<cstring>
#define MAXN 500001
using namespace std;
struct node{
 int data;
 int pos;
}a[MAXN];
int c[MAXN];
int n;
long long int ans;
bool cmp(node a,node b){
 if(a.data ==b.data ) return a.pos <b.pos ;
 return a.data <b.data ;
}
bool cmp1(node a,node b){
 return a.pos <b.pos ;
}
int lowbit(int x){
 return x&(-x);
}
void update(int x,int val){
     for(;x<=n;x+=lowbit(x))
  c[x]+=val;
}
int getsum(int x){
 int sum=0;
 for(;x;x-=lowbit(x)){
  sum+=c[x];
 }
 return sum;
}
int main(){
 while(1){
  ans=0;
  memset(c,0,sizeof(c));
  scanf("%d",&n);
  if(n==0) break;
  for(int i=1;i<=n;i++){
   scanf("%d",&a[i].data );
   a[i].pos =i;
  }
  sort(a+1,a+n+1,cmp);
  for(int i=1;i<=n;i++){
   a[i].data =i;
  }
  sort(a+1,a+n+1,cmp1);
  int t;
  for(int i=1;i<=n;i++){
   update(a[i].data ,1);
   t=i-getsum(a[i].data );
   ans+=t;
  }
  printf("%lld\n",ans);
 }
 return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值