【PAPI】新版内核(linux 2.6.32以上)上安装PAPI

 

Various features are now enabled or disabled at runtime based on kernel versioning, and support for the perf-counter interface in linux kernel 2.6.31 has been deprecated in favor of the perf-events interface in kernel 2.6.32 and above.

 

Linux 2.6.32及其以上的内核都支持 perf-events, 在支持 perf-events 的内核上 PAPI-4.1.1及其以上的版本 可以得到很好的支持,而不用像之前的老内核一样需要首先给内核安装 perfctr 补丁。

 

下面介绍其安装步骤:

 

(1)编译新内核见文章:http://blog.csdn.net/zklth/archive/2011/03/06/6226949.aspx

(2)安装PAPI步骤和之前 PAPI-3.6.0 一样,见: http://blog.csdn.net/zklth/archive/2010/09/28/5912599.aspx

 

    ./configure

    make

    make install

 

     

 

 

 

 

发布了221 篇原创文章 · 获赞 32 · 访问量 172万+
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 大白 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览